В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
joryk2012
joryk2012
10.05.2023 11:42 •  Информатика

1. дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 – рост учащихся выпускного класса. напишите программу, которая выводит номера элементов с максимальными и минимальными значениями. 2. дан целочисленный массив размерностью n (n –чётное число), заполненный случайными числами. упорядочить по возрастанию первую половину массива, вторую половину оставить без изменений.

Показать ответ
Ответ:
karinapolushin
karinapolushin
15.09.2020 23:53
1.
const n=12; 
var
  a:array[1..n] of integer;
  i,max,imax,min,imin:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)+150;
  Write(a[i]:4)
end;
writeln;
max:=a[1]; imax:=1;
min:=a[1]; imin:=1;
for i:=2 to n do 
 begin
 if a[i]>max then begin max:=a[i]; imax:=i; end;
 if a[i]<min then begin min:=a[i]; imin:=i; end;
 end; 
Writeln('max = a[',imax,'] = ',max,',  min = a[',imin,'] = ',min);
end.

Пример:
Исходный массив:
 170 165 194 186 165 161 174 172 177 191 158 181
max = a[3] = 194,  min = a[11] = 158

2.
const n=20; 
var
a:array[1..n] of integer;
i,j,c:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i],' ')
end;
Writeln;
for i:=1 to n div 2-1 do
  for j:=1 to n div 2-i do
    if a[j]>a[j+1] then
    begin c:=a[j]; a[j]:=a[j+1]; a[j+1]:=c end;
Writeln('Измененный массив:');
for i:=1 to n do Write(a[i],' ');
Writeln
end.

Пример:
Исходный массив:
16 3 1 18 10 -12 -23 19 -5 -5 0 10 13 14 17 14 6 22 25 -22 
Измененный массив:
-23 -12 -5 -5 1 3 10 16 18 19 0 10 13 14 17 14 6 22 25 -22
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота