1 Дан массив из n элементов. Требуется посчитать их сумму и произведение.
Формат входных данных
С клавиатуры вводится натуральное число n (n≤100) — размер массива. В следующей строке вводятся n элементов массива через пробел. Все элементы не превосходят по модулю 10 и являются целыми числами.
Формат выходных данных
Необходимо вывести два числа в одной строке — сумму и произведение всех элементов массива. Гарантируется, что эти числа не превосходят по модулю 109.
входные данные
2
5 6
выходные данные
11 30
namespace old4Test1
{
class Program
{
static void Main()
{
Console.WriteLine(IsFirstBiggerThanLast(123456));
Console.WriteLine(IsFirstBiggerThanLast(62514));
Console.WriteLine(IsFirstBiggerThanLast(1));
Console.WriteLine(IsFirstBiggerThanLast(12));
Console.WriteLine(IsFirstBiggerThanLast(105));
Console.ReadKey();
}
// Определите,какая цифра числа-первая или последняя больше. C#
private static bool IsFirstBiggerThanLast(int number)
{
Console.WriteLine(number);
var s = number.ToString();
return s[0] > s[s.Length - 1];
}
}
}
#include <stdio.h>
#include <windows.h>
int main()
{
SetConsoleCP(1251);
SetConsoleOutputCP(1251);
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;
for (int i=0; i<n; i++)
for (int j=0; j<n; j++)
{
printf("mas[%d][%d] = ", i+1, j+1);
scanf("%d",&mas[ i ][ j ]);
}
printf("\nВведенная матрица:\n");
for (int i=0; i<n; i++)
{
for (int j=0; j<n; j++)
{
printf("%d ",mas[ i ][ j ]);
}
printf("\n");
}
sum1=0;
sum2=0;
for (int i = 0; i<n; i++)
{
sum1 += mas[ i ][ i ];
sum2 += mas[ i ][ n-1-i ];
}
printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);
magik = true;
for (int i=0; i<n; i++)
{
if (sum1==sum2)
{
sum2=0;
for (int j=0; j<n; j++)
{
sum2 += mas[ i ][ j ];
}
} else { magik=false; break; }
}
if (magik==true)
{
for (int i=0; i<n; i++)
{
if (sum1==sum2)
{
sum2=0;
for (int j=0; j<n; j++)
{
sum2 += mas[ j ][ i ];
}
}
else { magik=false; break; }
}
}
if (magik==true)
printf("\nМатрица является магическим квадратом\n");
else
printf("\nМатрица не является магическим квадратом\n");
system("pause");
return 0;
}