Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
nyutasova
12.10.2020 12:17 •
Информатика
1.дан массив. все его элементы уменьшить на число а. 2.найдите произведение нечетных элементов массива в паскале , так что бы работало на компьютере и выдавала результат.
Показать ответ
Ответ:
45Эвлария
17.07.2020 21:26
Const n = 5;
var
a: array[1..n] of integer;
i, b: integer;
begin
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
end;
writeln();
read(b);
for i := 1 to n do
write(a[i] - b, ' ');
end.
const
n = 5;
var
a: array[1..n] of integer;
i, p: integer;
begin
p := 1;
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
if(odd (a[i])) then p *= a[i];
end;
writeln();
writeln(p);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
mrmrheik
30.06.2021 02:06
Сообщение 14-15 в разных ситуациях может быть воспринято по разному. поясните, что оно может означать в следующих ситуациях: -на вокзале -на уроке -на стадионе -в магазине...
Аurikа
02.02.2021 15:19
Определи форму условного оператора.НАЧАЛОУсловие?Блок 1Блок 2KOHELL...
111леся199
12.04.2020 20:58
Есть 2 кувшина емкостью 3 и 8 литров. как с только 2 этих кувшинов набрать 7 литров воды...
лейла20032
10.01.2021 22:56
Написать программу на pascal abc: дана последовательность действительных числе размерности n. подсчитать количество пар соседних противоположных чисел....
123478101934
04.08.2022 13:47
Нужно по инфе в кумире сделать лестницу, исполнитель...
Ravik2K
27.12.2020 08:36
В прямоугольном треугольнике КМР угол М равен 90о, угол К равен 60о. Длина катета КМ составляет 34. Найдите длину гипотенузы....
alicegluskin
01.12.2021 11:54
поставить слова на фразы...
godofwar171
30.09.2020 17:06
напишите небольшой рассказ на тему «памятные места моего региона (Тула) в истории нашей страны». в рассказе необходимо указать не менее двух памятных мест вашего региона (исторических...
5ти
04.08.2020 07:38
. обязательно с решением...
syaninp087af
20.04.2023 01:20
Поміркуй, що може завадити проростанню насінинки. Запиши свої ідеї стосовно того, як можна зарадити біді в кожному випадку.помиркуй что может сдаваться прорастанию на семёрке...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
a: array[1..n] of integer;
i, b: integer;
begin
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
end;
writeln();
read(b);
for i := 1 to n do
write(a[i] - b, ' ');
end.
const
n = 5;
var
a: array[1..n] of integer;
i, p: integer;
begin
p := 1;
for i := 1 to n do
begin
a[i] := random(0, 10);
write(a[i], ' ');
if(odd (a[i])) then p *= a[i];
end;
writeln();
writeln(p);
end.