В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Tinusya
Tinusya
13.10.2021 03:44 •  Информатика

№1. дана последовательность целых чисел. напишите программу, подсчитывающую, сколько в этой последовательности отрицательных чисел. №2. дана последовательность целых чисел. напишите программу, вычисляющую сумму положительных чисел.

Показать ответ
Ответ:
мединалуна
мединалуна
10.06.2020 02:04
№1                                        

program raf105;

var a,otr: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 if a<0

   then otr+= 1;

until a = 0;

writeln('Отрицательных чисел: ',otr);

end.

№2                                        

program raf105;

var a,sum: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 if a>0

   then sum+= a;

until a = 0;

writeln('Сумма положительных чисел: ',sum);

end.

                                              PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота