В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
annaegoshina
annaegoshina
28.07.2022 19:02 •  Информатика

1)дано трехзначное число.составьте программу которая определяет а)является ли сумма его цифр нечетным числом 2)составьте программу в которой осуществляется вот целых чисел до тех пор пока не будет введен 0 и подсчет а)количество чисел оканчивающихся на 6 и кратных 4 б)сумма чисел оканчивающихся на 6 и кратных 4 на языке паскаль

Показать ответ
Ответ:
danilgranin20
danilgranin20
06.10.2020 10:47
1)
Program hhh54;
var x:longint;
begin
  read (x);
  if ((x div 100) + ((x div 10) mod 10) + (x mod 10)) mod 2 <> 0 then write ('ЯВЛЯЕТСЯ')
  else write ('НЕ ЯВЛЯЕТСЯ');
end.

2)
а)
Progran hhh54;
var i,k,x:longint;
begin
  k:=0;
  read (x);
  while x <> 0 do
    begin
      if (x mod 10 = 6) and (x mod 4 = 0); then k:=k+1;
      read (x);
    end;
  write (k);
end.

б)
Progran hhh54;
var i,s,x:longint;
begin
  s:=0;
  read (x);
  while x <> 0 do
    begin
      if (x mod 10 = 6) and (x mod 4 = 0); then s:=s+x;
      read (x);
    end;
  write (s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота