В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
angelina2003po
angelina2003po
06.12.2020 21:59 •  Информатика

1. Даны два числа А и В. Запишите логическое выражение по правилам языка Паскаль: «Число А принадлежит отрезку (-2;2]»
2. Какая ошибка допущена в записи оператора. Запишите правильный ответ.
IF A Составьте блок-схему, соответствующую фрагменту программы.
3. Определите значение переменной «с» после выполнения фрагмента программы:
c:= 6; k:=4;
if c <2*k then c := sqrt(k)
else c:= k +1;

Показать ответ
Ответ:
daryamoskovskay
daryamoskovskay
11.04.2022 14:36
// PascalABC.NET 3.0, сборка 1128
begin
  var k:=ReadInteger('Укажите номер записи k:');
  var a:=ReadLines('T1.txt').Select(x->Length(x)).
         Where(x->x<>0).ToArray;
  var n:=a.Length;
  if k>n then Writeln('В файле записей меньше, чем ',k)
  else Writeln('Сумма равна ',a.Min+a[n-k+1])
end.

А теперь "школьный вариант"
// PascalABC.NET 3.0, сборка 1128
var
  t:text;
  min,l,m,n,k:integer;
  s:string;
begin
  k:=2; // вторая от конца запись
  Assign(t,'T1.txt'); Reset(t);
  min:=1000; m:=0;
  while not Eof(t) do begin
    ReadLn(t,s); Inc(m);
    l:=Length(s);
    if (l>0) and (l<min) then min:=l
    end;
  Close(t); Reset(t);
  k:=m-k+1;
  if k<1 then Writeln('В файле нет стольких строк')
  else begin
    m:=0;
    while m<>k do begin Readln(t,s); Inc(m) end;
    Writeln('Сумма равна ',min+Length(s))
    end;
  Close(t)
end.
0,0(0 оценок)
Ответ:
ilya1613
ilya1613
06.06.2022 23:41
Можешь там сократить что-нибудь

Что такое файл? Файлом (от англ. file — цепочка) называется последовательный набор данных, хранящийся на каком-либо физическом носителе и имеющий собственные имя и расширение. Расширение файла предназначено для однозначной и исчерпывающей идентификации типа файлового объекта; оно записывается справа от имени файла и отделяется от него точкой. В данном случае тип файлового объекта — это функциональная характеристика файла, с которой операционная система определяет набор программ обрабатывать или использовать данный файл. Если мы рассмотрим в качестве примера некий абстрактный файл README.TXT, то здесь именем файла является строка README, а его расширением — .ТХТ, которое указывает на то, что данный файловый объект относится к типу «текстовый файл» и может быть обработан с использованием какого-либо текстового редактора, например стандартной программы Блокнот из комплекта поставки Windows. Согласно устоявшейся практике, принято делить все многообразие существующих на сегодняшний день файлов на несколько различных классов по признаку их функционального применения. К первому из упомянутых выше классов относятся так называемые файлы пользователя — текстовые документы, рисунки, веб-страницы и прочие файловые объекты, создаваемые пользователем компьютера для какой-либо определенной цели или для собственных нужд. Для таких файлов пользователь может назначать произвольные имена, соответствующие, однако, принятому в Windows стандарту. Расширения пользовательских файлов, как правило, автоматически присваиваются им программами, при которых эти файлы создаются, либо указываются пользователем вручную исходя из типа каждого конкретного файлового объекта и его дальнейшего применения. Ко второму классу относятся системные файлы — то есть файлы, используемые операционной системой в процессе ее работы. Имена и расширения таких файлов заранее определены разработчиками Windows, и любое их изменение потенциально привести к нарушению работо системы. Третий класс включает программные файлы, используемые установленным на вашем компьютере программным обеспечением. Их имена и расширения назначаются разработчиками соответствующих программ. Как уже упоминалось выше, файловые объекты принято также классифицировать по их типам в соответствии с набором приложений, которые могут эти файлы обрабатывать, — в частности, к различным типам файлов относятся текстовые документы, документы Microsoft Word, архивы (файлы, содержащие какие-либо сжатые данные), исполняемые файлы (файлы, которые могут быть запущены в операционной системе в режиме программы) и т. д.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота