В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Маширо11
Маширо11
04.01.2023 19:08 •  Информатика

1. Даны два круг. Написать программу, которая выводит их площади и определяет, площадь какой фигуры больше. Формула площади круга S= πr2 (где π=3,14) Пример ввода
Введите радиус первого круга 4
Площадь первого круга равна 12,56
Введите радиус второго круга 2
Площадь второго круга равна 6,28
Площадь первого круга больше

Пример ввода
Введите число 3500
Результат 1,73
Пример ввода
Введите число -3500
Результат 3500
2. Если число трехзначное (взять только положительные числа), то разделить его на 2022 (с двумя знаками после запятой), иначе взять по модулю.
! В pascal

Показать ответ
Ответ:
VIP161
VIP161
15.05.2021 10:53

#define UPPERLIMIT 1000

#define LOWERLIMIT 0

#include <iostream>

#include <vector>

#include <cstddef>

#include <algorithm>

#include <ctime>

using namespace std;

class Massive {

public:

   virtual void fill() = 0;

   virtual int get_max() = 0;

   virtual int get_min() = 0;

   virtual void reverse(int start, int end) = 0;

   virtual void out() = 0;

};

class MassiveHandler : public Massive {

private:

   std::vector<int>::iterator result;

public:

   std::vector<int> array;

   MassiveHandler(std::size_t n) : array(n) {

       this->fill();

   }

   void fill() override {

       srand(time(0));

       for (int i = 0; i < this->array.size(); ++i)

           this->array[i] = rand() % (UPPERLIMIT - LOWERLIMIT + 1) + LOWERLIMIT;

   }

   void routine() {

       this->reverse(this->get_min(), this->get_max());

   }

   void reverse(int start_v, int end_v) override {

       if (start_v > end_v)

           swap(start_v, end_v);

       for (int i = start_v, j = end_v; i < j; i++, j--)

           swap(this->array[i], this->array[j]);

   }

   int get_max() override {

       this->result = std::max_element(this->array.begin(), this->array.end());

       return std::distance(this->array.begin(), result);

   }

   int get_min() override {

       this->result = std::min_element(this->array.begin(), this->array.end());

       return std::distance(this->array.begin(), result);

   }

   void out() override {

       for (int i = 0; i < this->array.size(); ++i)

           cout << this->array[i] << " ";

       cout << endl;

   }

};

int main() {

   int n;

   cin >> n;

   MassiveHandler *MH = new MassiveHandler(n);

   cout << "MAX: " << MH->array[MH->get_max()] << endl;

   cout << "MIN: " << MH->array[MH->get_min()] << endl;

   cout << endl;

   cout << "Before: ";

   MH->out();

   MH->routine();

   cout << "After:  ";

   MH->out();

}

0,0(0 оценок)
Ответ:
sdamna5uveren
sdamna5uveren
15.05.2021 10:53

#include <iostream>

#include <vector>

#include <algorithm>

#include <ctime>

using namespace std;

int main()

{

srand(time(NULL));

int n, max = 0, index1, min = 0, index2;

cin >> n;

cout << "RANDOM ARRAY:\n";

vector <int> a(n);

for (int i = 0; i < n; i++)

{

 a[i] = rand() % 101;

 if (a[i] > max) {

  max = a[i]; index1 = i;

 }

 if (a[i] < min || min == 0) {

  min = a[i]; index2 = i;

 }

 cout << a[i] << " ";

}

cout << "\nARRAY:\n";

if (index2 < index1)

{

 int x;

 x = index2;

 index2 = index1;

 index1 = x;

}

reverse(a.begin() + index1, a.begin() + index2);

for (int i = 0; i < n; i++)

{

 cout << a[i] << " ";

}

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота