В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

1. Даны катеты А и В прямоугольного треугольника. Создать программу на паскаль, которая вычисляет Гипотенузу, Площадь, Периметр данного треугольника. 2. Дан радиус R окружности. Написать программу, которая вычисляет площадь и длину окружности. 3. Даны коэффициенты А,В,С квадратного уравнения. Создать программу, которая вычисляет дискриминант и корни данного уравнения.

Показать ответ
Ответ:
daniilkartel
daniilkartel
05.10.2022 17:56

var

  a: array[1..1000] of real;

  i, k, n, z: integer;

begin

  writeln('введите число n: ');

  readln(n);

  writeln('введите число z: ');

  readln(z);

  writeln('введите ',n,' действительных чисел (каждое с новой строки): ');

  for i : = 1 to n do

  begin

    readln(a[i]);

    if a[i] > z then

    begin

      a[i] : = z;

      k : = k + 1;

    end;

  end;

  writeln('количество замен: ', k);

end.

0,0(0 оценок)
Ответ:
elisavetto4ka
elisavetto4ka
05.08.2020 22:02

1)

var

  a: 100..999;

  a1, a2, a3: 0..9;   //а1 - сотни, а2 - десятки, а3 - единицы

 

begin

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a1, a3, a2);

end.

2)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin

   

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a2, a1, a3);

end.

3)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin 

  writeln('введите натуральное трехзначное число');

  readln(a);

  a1: = a div 100;

  a2: = (a mod 100) div 10;

  a3: = a mod 10;

  writeln('полученное число:   ', a3, a1, a2, a3);

end.

4)

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;

 

begin

  writeln('введите натуральное четырехзначное число');

  readln(a);

  a1: = a div 1000;   //тысячи

  a2: = (a mod 1000) div 100;   //сотни

  a3: = (a mod 100) div 10;   //десятки

  a4: = a mod 10;   //единицы

  writeln('полученное число:   ', a4, a3, a2, a1);

end.

все остальное делается наподобие этого: просто в writeln меняешь местами цифры и все.

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота