1)Из 30 учащихся класса на уроке присутствуют 24 ученика. Напишите программу, высчитывающую процент посещаемости в этом классе 2)Дан интервал времени в часах,минутах и секундах.Напишите программу, которая определит тот же интервал в секундах
Программирование надо
Объяснение:
Шоколадка
Степан вирішив пригостити однокласників шоколадками. Шоколадка коштувала N грн. З першого листопада вартість шоколадки збільшилась рівно на Р відсотків. Визначте скільки шоколадок зможе купити Степан на S грн після подорожчання.
Формат вхідних даних:
У першому рядку задано число N (1 ≤ N ≤ 107) - вартість шоколадки до подорожчання. У другому рядку Р (0 ≤ Р ≤ 100) - величина подорожчання шоколадки у відсотках. В третьому рядку - S (1 ≤ S ≤ 107) - сума грошей, яка є у Степана.
Формат вихідних даних:
Виведіть одне число - кількість шоколадок, які може купити Степан.
Код программы:
#include <iostream>
#include <locale>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
double D, a, b, c, x1, x2;
cout<<"Введите коэффициент a" << endl;
cin >> a;
if (a == 0) {
cout << "Ошибка ввода! Коэффициент a не должен равняться 0" << endl;
return 0;
}
cout << "Введите коэффициент b" << endl;
cin >> b;
cout << "Введите коэффициент c" << endl;
cin >> c;
cout << "\nВаше уравнение: " << a << "x^(2) + " << b << "x + " << c << endl;
D = sqrt(b*b - 4 * a * c);
if (D >= 0) {
if (D == 0) {
x1 = (-b) / (2 * a);
cout << "x1 = " << x1 << endl;
}
else {
x1 = (-b - D) / (2 * a);
x2 = (-b + D) / (2 * a);
cout << "x1 = " << x1 << endl;
cout << "x2 = " << x2 << endl;
}
}
else
cout << "\nУравнение не имеет корней (D < 0)" << endl;
return 0;
}