1. Какую команду нужно выполнить, чтобы открыть новое окно в программе? 2. Что означает синтаксис языка? 3. Какие алгоритмы называются линейным? 4. Как вы понимаете типов данных? 5. Найти ошибки в программе: a=int (input(“введи a”)) b=int(input введи b) a=a+1 b=b+1 print(“сумма” a-b) 7. Составьте программу так, чтобы из слова “Информатика” вышло обратное слово “акитамрофнИ” 8. Приведите пример числовых и вещественных данных 9. Составьте два списка. В первом списке напишите название 5 фильмов, а во втором 5 героев. Составьте программу, чтобы 2 списка объединились 10. Напишите комментарии к данной программе: text = “Компьютер” print (text [0:9]) print (text [0:7]) print (text [-4]) print (text [::3])
begin
readln(n);
if n=1 then begin writeln('1 месяц');writeln('кол-во дней');end;
if n=2 then begin writeln('2 месяц');writeln('кол-во дней');end;
if n=3 then begin writeln('3 месяц');writeln('кол-во дней');end;
if n=4 then begin writeln('4 месяц');writeln('кол-во дней');end;
if n=5 then begin writeln('5 месяц');writeln('кол-во дней');end;
if n=6 then begin writeln('6 месяц');writeln('кол-во дней');end;
if n=7 then begin writeln('7 месяц');writeln('кол-во дней');end;
if n=8 then begin writeln('8 месяц');writeln('кол-во дней');end;
И так до 12 раз...
Я не уверен что тебе нужен такой монстр...
В место к примеру 1 месяца пишешь январь...
begin
var s:=ReadLines('in.txt').ToArray;
var n:=StrToInt(s[0]);
var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
var f:=OpenWrite('out.txt');
Writeln(f,n,' - (кол-во чисел)');
foreach var e in a do Write(f,e,' '); Writeln(f);
Writeln(f,'Среднее значение четных ',
a.Where(x->x.IsEven).Average);
Writeln(f,'Среднее значение нечетных ',
a.Where(x->x.IsOdd).Average);
f.Close
end.
Файлы in.txt и out.txt находятся во вложении.
Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25