В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

1.На входе программы есть два целых числа, каждое в отдельной строке. На выход нужно подать сумму заданных чисел.
Входные данные
Два целых числа, записанных в столбик.
Выходные данные
Сумма заданных чисел.
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
12
9
ответ №1
21
2. Вам дано ціле число n. Також є три види операцій:
Зменшити n на 1.
Збільшити n на 1.
Якщо n ділиться націло на 3, поділити n на 3.
За яку мінімальну кількість операцій можна зробити число n рівним 1?
Входные данные
Перший рядок містить одне ціле число n (1≤n≤1018).
Выходные данные
Виведіть одне число — мінімальну кількість операцій, за яку можна зробити число n рівним 1.
Заметка
У першому прикладі можна один раз поділити на 3 і отримаємо 1.
У другому прикладі можна спочатку двічі зменшити n на 1, а потім поділити на 3.
Оценивание
Рішення, які працюють правильно для обмежень 1≤n≤105, набиратимуть 40% балів.
Примеры
Ниже вы найдете примеры входных данных и ответов, которые должна вывести ваша программа.
Входные данные №1
3
ответ №1
1
Входные данные №2
5
ответ №2
3
Входные данные №5
70109
ответ №5
18

Показать ответ
Ответ:
kiyash98
kiyash98
17.10.2022 20:08

program z1;

var n,k:integer;

begin

k:=0;

write ('Введите натуральное число (n>9): ');

readln (n);

write ('Цифры натурального числа ',n);

while n>=10 do

begin

if n mod 10 < n div 10 mod 10 then k:=1;

n:=n div 10

end;

if k=1 then write (' НЕ расположены в порядке возрастания')

else write (' расположены в порядке возрастания')

end.

Объяснение:

Вводим число

Цикл с предусловием (условие число больше или равно 10)

Сравнение последней и предпоследней цифр числа, если последняя меньше, то k присваивается значение 1

n присваивается значение целочисленного деления на 10 (отбрасываем последнюю цифру числа)

Если k = 1, то цифры не расположены в порядке возрастания, иначе расположены

0,0(0 оценок)
Ответ:
Vera4441
Vera4441
09.01.2020 17:11

1.

def func(x,y,xc,yc,r):

   return (x - xc)**2+ (y - yc)**2 <= r**2

x=float(input())

y=float(input())

xc=float(input())

yc=float(input())

r=float(input())  

if func(x, y, xc, yc, r):

   print("YES")

else:

   print("NO")

2.

with open("input.txt") as f:

   massiv=list(map(int,f.read().split("\n")))

with open("output.txt","w") as f:

   for i in massiv:

       if i==3:

           f.write("win\n")

       elif i==1:

           f.write("draw\n")

       elif i==0:

           f.write("lose\n")

3.

with open("input.txt") as f:

   massiv=list(map(int,f.read().split("\n")))

with open("output.txt","w") as f:

   if massiv[0]>massiv[1]:

       f.write("Alexander is the eldes.")

   elif massiv[0]<massiv[1]:

       f.write("Tatyana is the eldest.")

   else:

       f.write("Nobody is the eldest.")

4.

with open("input.txt") as f:

   massiv=list(map(float,f.read().split("\n")))

with open("output.txt","w") as f:

   for i in massiv:

       if i<=0:

           f.write("ice\n")

       elif i>=100:

           f.write("water vapor\n")

       else:

           f.write("water\n")

5.

with open("input.txt") as f:

  massiv=list(map(int,f.read().split("\n")))

with open("output.txt", "w") as f:

  for i in range(0,len(massiv), 2):

      if massiv[i]/massiv[i+1]<=1:

          f.write("Traffic rules are executed. \n")

      else:

          f.write("Traffic rules are not met. \n")

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота