В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
satursacha
satursacha
29.11.2020 01:36 •  Информатика

1.Написать логическое условие на языке python 1) каждое из чисел x и у положительно
2) числа x и у имеют разные знаки
2.Определите значение временных после выполнения алгоритмов:
а=10
b=b//2
b=a%3
a=b-a
в=15
3. создать блок схему по данному алгоритму.
если х>0 и х<10
у=х*х+3
иначе у=7

Показать ответ
Ответ:
PomogiteDimePleaz
PomogiteDimePleaz
28.05.2022 21:40

class NumProcessor():

def __init__(self, length, endSymb):

 self.main_buffer = []

 self.search_lengt = length  

 self.search_endSymbol = endSymb

def addNum(self, *nums):

 for num in nums:

  self.main_buffer.append(num)

def sortLen(self, length, array):

 for item in array:

  if len(str(item)) == length:

   yield item  

def sortEndSymb(self, symbol, array):

 for item in array:

  if str(item)[-1] == str(symbol):

   yield item

def sort(self):

 servBufferlen = [int(i) for i in self.sortLen(self.search_lengt, self.main_buffer)]

 servBufferendSym = [int(i) for i in self.sortEndSymb(self.search_endSymbol, servBufferlen)]

 return min(servBufferendSym)

def insert_nums():

result = []

print('What count of numbers you want to process?\n')

n = int(input())

for i in range(n):

 result.append(input())

return result

def main():

processor = NumProcessor(3, '6')

processor.addNum(*insert_nums())

result = processor.sort()

if len(result) == 0:

 print('НЕ НАЙДЕНО')

else:

 print(result)

if __name__ == '__main__':

main()

input()

Объяснение:

Код протестирован и работает. Копировать с сайта не нужно, ибо ломаются табуляции в коде. Вы можете ознакомиться с решением задания и попытаться повторить это самостоятельно, или попросить в комментариях меня, я залью этот код на pastebin.com и дам вам ссылку, оттуда можно спокойно будет скопировать решение. Ниже приложен скриншот оригинала кода


На обработку поступает последовательность из n натуральных чисел. на вход программе сначала подается
0,0(0 оценок)
Ответ:
Tittans104
Tittans104
06.01.2023 02:49

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_ALL, "russian");

int n = 20;

int* mas;

mas = new int[n];

for (int i = 0; i < n; i++)

{

 mas[i] = rand() % 10;

 cout << mas[i] << " ";

}

cout << endl;

for (int i = 0; i < n - 1; i++)

{

 int min = i;

 for (int j = i + 1; j < n; j++)

  if (mas[j] < mas[min])

   min = j;

 swap(mas[i], mas[min]);

}

for (int i = 0; i < n; i++)

{

 cout << mas[i] << " ";

}

cout << endl;

int sum = 0;

for (int i = n-5; i < n ; i++)

{

 sum += mas[i];

}

cout << endl << " sum=" << sum;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота