В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

1. написать программу для решения : точки на плоскости заданы своими координатами. определить какая из них находится ближе к началу координат.

Показать ответ
Ответ:
Криш7771
Криш7771
01.10.2020 14:11
Uses crt;
var n,minind,i:integer;
min,x,y:real;
begin
writeln('Введите количество точек: ');
read(n);
writeln('Вводите по очереди координаты x и y точек.');
read(x,y);
min:=sqr(x)+sqr(y);
minind:=1;
for i:=2 to n do
begin
read(x,y);
if sqr(x)+sqr(y)<min then
begin
min:=sqr(x)+sqr(y);
minind:=i;
end;
end;
writeln('Точка под номером ',minind,'.');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота