В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
gri6anja20021
gri6anja20021
03.06.2020 00:45 •  Информатика

1.Написать программу и записи и ее индекса по введенной фамилии.
2.Написать программу для формирования трех файлов для записи и сохранения информации – фамилия, имя, отчество.
В

Показать ответ
Ответ:
KarinkaChernov
KarinkaChernov
03.01.2023 04:29
Const
  nn = 20;
  mm = 20;

var
  a: array[1..nn, 1..mm] of integer;
  i, j, m, n, n1,n2,sj: integer;

begin
  { Формирование массива и вывод его элементов.
    Попутный подсчет количества четных и нечетных элементов }
  n1:=0; n2:=0;
  Write('Введите через пробел число строк и столбцов массива: ');
  Readln(n, m);
  Randomize;
  Writeln('Исходный массив');
  for i := 1 to n do
  begin
    for j := 1 to m do
    begin
      a[i, j] := Random(101) - 50;
      Write(a[i, j]:4);
      if (a[i,j] mod 2=0) then n2:=n2+1 else n1:=n1+1
    end;
    Writeln
  end;
  { Сравнение и ветвление }
  if n2>n1 then
    { Уменьшить вдвое все положительные элементы }
  begin
    Writeln('Результирующий массив');
    for i:=1 to n do
    begin
      for j:=1 to m do
      begin
        if a[i,j]>0 then a[i,j]:=a[i,j] div 2;
        Write(a[i,j]:4)
      end;
      Writeln
    end
  end
  else
  begin
    { Найти суммы отрицательных элементов каждого столбца }
    Writeln('Суммы отрицательных элементов по столбцам');
    for j:=1 to m do
    begin
      sj:=0;
      for i:=1 to n do
        if a[i,j]<0 then sj:=sj+a[i,j];
      Write(sj,' ')
    end
  end
end.

Тестовое решение:
Введите через пробел число строк и столбцов массива: 8 5
Исходный массив
  13 -23  25   2 -36
 -19  47  -7 -24 -34
 -21  12 -29  46 -46
  18  -3  12 -26  -8
 -36 -39 -27 -48 -44
 -25  -4 -23 -11 -15
  49  24  -5  28  32
 -37 -32 -34  39  45
Суммы отрицательных элементов по столбцам
-138 -101 -125 -109 -183
0,0(0 оценок)
Ответ:
anuta00002000
anuta00002000
03.01.2023 04:29
Const n=10;
Var a:array[1..n] of integer;
i,k,j:integer;
Begin
Randomize;
    For i:=1 to n do  
       Begin 
         A[i]:=Random(10); 
         Write(a[i],' ');
     end;

          Writeln;

      For i:=1 to n do
           Begin
             If a[i] mod 3=0 then
             Write(a[i],' '); 
      end;
                   
for i:=1 to n-1 do
        for j:=1 to n-i do
            begin
                if (a[j] > a[j+1]) then
                    begin
                        k:= a[j];
                        a[j] := a[j+1];
                        a[j+1] := k;
                    end; 
                  end;  
                                       writeln;
                          for i:=1 to n do 
       write(a[i],' ');
        readln; 
     end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота