В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
apiloota
apiloota
23.11.2021 16:50 •  Информатика

1. написать программу которая ищет n! (цикл while)2. написать программу, которая находит число р = (1-1/2)(1-1/3)**(1-1/n). n вводится с клавиатуры. (цикл for)

Показать ответ
Ответ:
fdhhivanova00
fdhhivanova00
29.05.2020 12:06

Объяснение:

1.

var

 k:integer;

 p:integer;

 n:integer;

begin

 readln(n);

 

 p:=1;

 k:=1;

 

 while (k <= n) do begin

   p:=p*k;

   k:=k+1;

 end;

 

 writeln(p);

 

end.

2.

var

 k:integer;

 p:real;

 n:integer;

begin

 readln(n);

 

 p:=1;

 

 for k:=2 to n do begin

   p:=p*(1 - (1/k));

 end;

 

 writeln(p);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота