В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

1. написать программу, которая запрашивает массив размерности n и выводит на экран сам массив, а также наибольший и наименьший элементы массива. протестировать программу на массивах размерностью 5 элементов. 2. написать программу, которая запрашивает массив из n элементов, а затем делит все элементы массива на минимальный элемент. протестировать программу на масси- вах размерностью 5 элементов. 3. написать программу, которая запрашивает массив из n элементов и увеличивает все элементы массива на максимальный элемент. протестировать программу на массивах размерностью 8 элементов.

Показать ответ
Ответ:
александра7896
александра7896
12.06.2020 16:03
1.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of integer;

 x,max,min,i: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

max:= a[1];

min:= a[1];

for i:=1 to n do

begin

 if max < a[i]

   then max:= a[i];

 if min > a[i]

   then min:= a[i];

end;

writeln;

write('Массив: ');

for i:=1 to n do

 write(a[i],' ');

writeln;

writeln('Наибольший элемент: ',max);

writeln('Наименьший элемент: ',min);

end.

2.                                        

program raf105;

const

 n = 5;

var

 a: array[1..n] of real;

 x,i: integer;

 min: real;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

min:= a[1];

for i:=1 to n do

 if min > a[i]

   then min:= a[i];

for i:=1 to n do

 a[i]:= a[i]/min;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

3.                                        

program raf105;

const

 n = 8;

var

 a: array[1..n] of integer;

 x,i,max: integer;

begin

writeln('Введите ',n,' по очереди');

for i:=1 to n do

 readln(a[i]);

writeln;

write('Исходный массив: ');

for i:=1 to n do

 write(a[i],' ');

max:= a[1];

for i:=1 to n do

 if max < a[i]

   then max:= a[i];

for i:=1 to n do

 a[i]:= a[i]+max;

writeln;

write('Изменённый массив: ');

for i:=1 to n do

 write(a[i],' ');

end.

                                          PascalABC 3.4.2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота