1. Написать программу на VBA, реализующую следующий алгоритм: Радиус шара S=4πR2
Рассчитать радиус для введенного R
2. Написать программу на VBA, реализующую следующий алгоритм:
Написать программу для расчета стоимости абонемента.
Стоимость билета 1000 рублей
При покупке 3х билетов, предоставляется скидка 10%
При покупке 4-7 билетов – скидка 20%
При покупке более 7 билетов – скидка 30%
Вводится количество билетов. Выводится общая стоимость билетов.
Протестировать программу для покупки 2х билетов, 4х билетов, 10 билетов.
Программу реализовать с оператора Case.
Написать блок-схему программы.
1. + n 3 8 9 8
2 n 7 5 m
m 8 5 n 3
ясно, что основание искомой с/с > 10. Проверим и удостоверимся, что в 11c|c действия выполняются верно.
11 c|c M=6 n = 4
ответ: основание системы 11, m=6, n=4
2. m m 65 n
+2 n 4 4 m
5 5 4 2 4 очевидно, что основание искомой с/с > 6.
Проверим по действиям в 7 с/с, при сложении в столбик,
при m=3 и n=1
и удостоверимся, что всё верно.
ответ: осн. с\с = 7, m=3, n=1
3. пусть основание с\с будет X? тогда:
(4*X^2+X+5)*4 =2*X^3+2*X^2+6*X+6
раскрываем скобки, преобразуем и получаем уравнение:
(2*X - 14)*(X^2+1) = 0 ---> X=7
ответ:7
from itertools import product
i = open('input.txt', 'r')
o = open('output.txt', 'w+')
l = int(i.
alpha = "245"
d = []
for s in product(alpha, repeat=l):
d.append([" ".join(
for q in d[1: ]:
s = " ".join(q)
if int(s.count('2')) > 2:
continue
o.write(" ".join(q) + '\n')
i.close()
o.close()
код к : «перевод кода с питона на паскаль»
var
n,c,i,ost,b,t,d: integer;
a,k: string;
begin
readln(n);
c: =1;
for i: =1 to n do
c: =c*3;
c: =c-1;
for i: =1 to c do
begin
k: ='';
b: =i;
t: =0;
while b> 0 do
begin
ost: =b mod 3;
if ost=0 then inc(t);
d: =(-sqr(ost)+5*ost+4)div 2;
str(d,a);
k: =a+k;
b: =b div 3;
end;
while length(k)do
begin
k: ='2'+k;
inc(t);
end;
if t< =2 then writeln(k);
end;
end.