1)написать программу на языке паскаль,которая вычисляет среднее арифметическое пяти любых чисел. 2) написать программу на языке паскаль,вычисляющую корни квадратного уравнения.
1) program average; var i: integer; answer, S, tmp: real; begin for i := 1 to 5 do begin readln(tmp); S := S + tmp end; answer := S / 5; writeln(answer) end. 2) program equation; var A, B, C, D, x1, x2: real; begin writeln('ввеедите коэфициенты квадратного многочлена'); readln(A); readln(B); readln(C); if A <> 0 then begin D := B*B - 4*A*C; if D < 0 then writeln('действительных корней нет') else if D = 0 then begin x1 := -B/(2*A); writeln('Единственный корень: ',x1) end else begin x1 := (-B + sqrt(D)) / (2*a); x2 := (-B - sqrt(D)) / (2*a); writeln('Два корня: ',x1,', ',x2) end; end else writeln('старший коэфициент не может равняться 0') end.
program average;
var
i: integer;
answer, S, tmp: real;
begin
for i := 1 to 5 do
begin
readln(tmp);
S := S + tmp
end;
answer := S / 5;
writeln(answer)
end.
2)
program equation;
var
A, B, C, D, x1, x2: real;
begin
writeln('ввеедите коэфициенты квадратного многочлена');
readln(A);
readln(B);
readln(C);
if A <> 0 then
begin
D := B*B - 4*A*C;
if D < 0 then
writeln('действительных корней нет')
else if D = 0 then
begin
x1 := -B/(2*A);
writeln('Единственный корень: ',x1)
end else
begin
x1 := (-B + sqrt(D)) / (2*a);
x2 := (-B - sqrt(D)) / (2*a);
writeln('Два корня: ',x1,', ',x2)
end;
end
else writeln('старший коэфициент не может равняться 0')
end.