В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dasha1949
dasha1949
08.11.2022 11:24 •  Информатика

1. написать программу в python которая позволяет ввести и вывести данные в файл.

2. написать программу в python, которая удаляет все слова в файле, которые содержат в себе цифры.

Показать ответ
Ответ:
rukonya2009
rukonya2009
23.04.2023 06:55

#include <iostream>  

using namespace std;

void max(float a[])

{

for(int i2 = 0; i2<3; ++i2)  // сортируем массив

{

for(int i = 0; i<2; ++i)

{

if(a[i]>a[i+1])

{

 int temp1, temp2;

 temp2=a[i];

 temp1=a[i+1];

 a[i]=temp1;

 a[i+1]=temp2;

}

}

}

cout << "Max: " << a[2];  // выводим последний и наибольший элемент

}

int main()

{

cout << "Enter three numbers. ";

float a[3];  // float для поддержки дробных чисел

for(int i = 0; i<3; ++i)

{

cout << endl << "Number #" << i << ": ";

cin >> a[i];  

}

max(a);

}

0,0(0 оценок)
Ответ:
vadimkakuz200
vadimkakuz200
28.09.2020 22:14

Смотри картинки

Объяснение:

3.

Пусть Чертёжник в точке с начальными координатами (x, y).

Чтобы узнать где после всех команд сместиться на вектор оказался Чертёжник надо сложить все указанные команды, отдельно по каждой оси.

x = 3 + 1 + (-1) + 0 = 3 + 1 - 1 + 0 = 3

y = 3 + 0 + (-1) + 1 = 3 + 0 - 1 + 1 = 3

Чертежник оказался в точке с координатами (x +3, y +3).

Чтобы вернуться в исходную точку надо заменить узнанные векторы противоположными:

сместиться на вектор (-3, -3)

4.

После выполнения команды сместиться на вектор (a, b), Чертёжник оказывается в точке (x + a, y + b), относительно начальных координат (x, y).

начальные координаты (1, 1)

Т.к. цикл должен повториться 3 раза, то выполним указанные в нём команды 3 раза.

начальные координаты (1, 1)

сместиться на вектор (2, 0) - Чертёжник оказывается в точке (3, 1)

начальные координаты (3, 1)

сместиться на вектор (0, 1) - Чертёжник оказывается в точке (3, 2)

начальные координаты (3, 2)

сместиться на вектор (2, 0) - Чертёжник оказывается в точке (5, 2)

начальные координаты (5, 2)

сместиться на вектор (0, 1) - Чертёжник оказывается в точке (5, 3)

начальные координаты (5, 3)

сместиться на вектор (2, 0) - Чертёжник оказывается в точке (7, 3)

начальные координаты (7, 3)

сместиться на вектор (0, 1) - Чертёжник оказывается в точке (7, 4)

Смещения по оси x вправо и по оси y вверх - положительные.

Смещения по оси x влево и по оси y вниз - отрицательные.


HELP HELP HELP HELP HELP HELP HELP HELP HELP HELP HELP HELP ​
HELP HELP HELP HELP HELP HELP HELP HELP HELP HELP HELP HELP ​
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота