В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Maximismailov281
Maximismailov281
25.06.2022 09:32 •  Информатика

1.написать программу вычисления суммы четных элементов массива,состоящего из 10 чисел,заполненных случайным образом от10 до30.

Показать ответ
Ответ:
castlecrashers
castlecrashers
20.10.2022 14:41

import re

password = []

def validate_password(password):

   input_str = input('Введите пароль: ')

   def _validate_symbols(input_str):

       return input_str.isalnum()

   _validate_symbols(input_str)

   if _validate_symbols(input_str) == True:

       pass

   else:

       password.append('содержит запрещенные символы')

   def _validate_letters_even(input_str):

       count_letter = (len(re.sub('[^a-zA-Z]+', '', input_str)))

       if count_letter != 0 and count_letter % 2 == 0:

           return True

       else:

           password.append('не содержит четного кол-ва букв')

           return False

   _validate_letters_even(input_str)

   def _validate_numbers_odd(input_str):

       count_digits = sum([ 1 for s in input_str if s.isdigit() ])

       if count_digits != 0 and count_digits % 2 == 0:

           return True

       else:

           password.append('не содержит четного количества цифр')

           return False

   _validate_numbers_odd(input_str)

   if len(password) == 0:

       return True

   else:

       print(password)

   return password

validate_password(password)

Объяснение:

если есть вопросы пиши, функции сам только начал изучать, чуть голова не лопнула)) В конце validate_password(password) можно воткнуть в print() чтобы увидеть что дейтвительно возращает True

0,0(0 оценок)
Ответ:
aysol
aysol
01.03.2022 18:50

#include <iostream>

#include <vector>

using namespace std;

int main()

{

   int n;

   cin >> n;

   vector<int> v(n);

   for (int i = 0; i < n; ++i){

       cin >> v[i];

   }

   for (int i = 0; i < n; ++i){

       bool flag = false;

       for (int j = 0; j < i; ++j){

           if (v[i] == v[j]){

               flag = true;

           }

       }

       for (int j = i + 1; j < n; ++j){

           if (v[i] == v[j]){

               flag = true;

           }

       }

       if (flag == false){

           cout << v[i] << " ";

       }

   }

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота