В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Зимаа1
Зимаа1
16.04.2023 17:03 •  Информатика

. 1. Написать программу, выводящую на экран "да", если буква "а" есть в слове, "нет", если буквы в слове нет. Слово вводится с клавиатуры. 2. Написать программу, определяющую кол-во слов в предложении. Предложение вводится пользователем с клавиатуры. (для подсчёта слов используется кол-во пробелов. Делаю в паскале )

Показать ответ
Ответ:
lyuda29m
lyuda29m
05.12.2020 18:01

var

 a, // элемент последовательности

    // натуральных чисел (<=30000)

 i, // порядковый номер элемента а

 n, // количество элементов а (<=1000)

 m: // минимальное четное двузначное число

    // среди элементов а

 integer;

begin

 read(n);

 m := 98;

 for i := 1 to n do

 begin

   read(a);

   if (a >= 10) and (a <= 99) and (a mod 2 = 0) and (a < m) then

     m := a;

 end;

 write(m);

end.

Объяснение:

Не форматированный код:

var

a, // элемент последовательности

// натуральных чисел (<=30000)

i, // порядковый номер элемента а

n, // количество элементов а (<=1000)

m: // минимальное четное двузначное число

// среди элементов а

integer;

begin

read(n);

m := 98;

for i := 1 to n do

begin

read(a);

if (a >= 10) and (a <= 99) and (a mod 2 = 0) and (a < m) then

m := a;

end;

write(m);

end.


Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное дву
Напишите программу, которая в последовательности натуральных чисел определяет минимальное четное дву
0,0(0 оценок)
Ответ:
snady
snady
07.02.2020 02:42

using UnityEngine;

using System.Collections;

[RequireComponent(typeof(Rigidbody2D))]

public class Player2DControl : MonoBehaviour {

public enum ProjectAxis {onlyX = 0, xAndY = 1};

public ProjectAxis projectAxis = ProjectAxis.onlyX;

public float speed = 150;

public float addForce = 7;

public bool lookAtCursor;

public KeyCode leftButton = KeyCode.A;

public KeyCode rightButton = KeyCode.D;

public KeyCode upButton = KeyCode.W;

public KeyCode downButton = KeyCode.S;

public KeyCode addForceButton = KeyCode.Space;

public bool isFacingRight = true;

private Vector3 direction;

private float vertical;

private float horizontal;

private Rigidbody2D body;

private float rotationY;

private bool jump;

void Start ()  

{

 body = GetComponent<Rigidbody2D>();

 body.fixedAngle = true;

 if(projectAxis == ProjectAxis.xAndY)  

 {

  body.gravityScale = 0;

  body.drag = 10;

 }

}

void OnCollisionStay2D(Collision2D coll)  

{

 if(coll.transform.tag == "Ground")

 {

  body.drag = 10;

  jump = true;

 }

}

 

void OnCollisionExit2D(Collision2D coll)  

{

 if(coll.transform.tag == "Ground")

 {

  body.drag = 0;

  jump = false;

 }

}

 

void FixedUpdate()

{

 body.AddForce(direction * body.mass * speed);

 if(Mathf.Abs(body.velocity.x) > speed/100f)

 {

  body.velocity = new Vector2(Mathf.Sign(body.velocity.x) * speed/100f, body.velocity.y);

 }

 if(projectAxis == ProjectAxis.xAndY)

 {

  if(Mathf.Abs(body.velocity.y) > speed/100f)

  {

   body.velocity = new Vector2(body.velocity.x, Mathf.Sign(body.velocity.y) * speed/100f);

  }

 }

 else

 {

  if(Input.GetKey(addForceButton) && jump)

  {

   body.velocity = new Vector2(0, addForce);

  }

 }

}

void Flip()

{

 if(projectAxis == ProjectAxis.onlyX)

 {

  isFacingRight = !isFacingRight;

  Vector3 theScale = transform.localScale;

  theScale.x *= -1;

  transform.localScale = theScale;

 }

}

 

void Update ()  

{

 if(lookAtCursor)

 {

  Vector3 lookPos = Camera.main.ScreenToWorldPoint(new Vector3(Input.mousePosition.x, Input.mousePosition.y, Camera.main.transform.position.z));

  lookPos = lookPos - transform.position;

  float angle  = Mathf.Atan2(lookPos.y, lookPos.x) * Mathf.Rad2Deg;

  transform.rotation = Quaternion.AngleAxis(angle, Vector3.forward);

 }

 if(Input.GetKey(upButton)) vertical = 1;

 else if(Input.GetKey(downButton)) vertical = -1; else vertical = 0;

 if(Input.GetKey(leftButton)) horizontal = -1;

 else if(Input.GetKey(rightButton)) horizontal = 1; else horizontal = 0;

 if(projectAxis == ProjectAxis.onlyX)  

 {

  direction = new Vector2(horizontal, 0);  

 }

 else  

 {

  if(Input.GetKeyDown(addForceButton)) speed += addForce; else if(Input.GetKeyUp(addForceButton)) speed -= addForce;

  direction = new Vector2(horizontal, vertical);

 }

 if(horizontal > 0 && !isFacingRight) Flip(); else if(horizontal < 0 && isFacingRight) Flip();

}

ИЛИ

using UnityEngine;

using System.Collections;

public class Move : MonoBehaviour {

public GameObject player;

public int speedRotation = 3;

public int speed = 5;

public AnimationClip anima;

public int jumpSpeed = 50;

void Start () {  

 player = (GameObject)this.gameObject;  

 animation.AddClip(anima, "animCube");

 }

 void Update(){

if (Input.GetKey(KeyCode.W) || Input.GetKey(KeyCode.UpArrow))  

 {  

 player.transform.position += player.transform.forward * speed * Time.deltaTime;  

 animation.CrossFade("animCube");

 }  

if (Input.GetKey(KeyCode.S) || Input.GetKey(KeyCode.DownArrow))  

 {  

 player.transform.position -= player.transform.forward * speed * Time.deltaTime;  

 }  

if (Input.GetKey(KeyCode.A) || Input.GetKey(KeyCode.LeftArrow))  

 {  

 player.transform.Rotate(Vector3.down * speedRotation);  

 }  

 if (Input.GetKey(KeyCode.D) || Input.GetKey(KeyCode.RightArrow))  

 {  

 player.transform.Rotate(Vector3.up * speedRotation);  

 }  

if (Input.GetKeyDown(KeyCode.Space))  

 {  

 player.transform.position += player.transform.up * jumpSpeed * Time.deltaTime;  

 }  

}

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота