1. напишите программу которая будет запрашивать у пользователя 4 числа, первых три числа программа будет суммировать, а последнее вычитать и выводить на экран. на основании кода программы составьте блок схему не обяз.
2. напишите программу которая будет запрашивать у пользователя прогноз погоды на три дня и выводить его на экран. на основании кода программы составьте блок схему
1) В результате умножения ip и маски первые 2 байта останутся теми же, что в ip, а последний байт станет равен 0
Что мы сейчас имеем: Адрес сети - 12.16.x.0
Найдем x:
Переведем 3 байт (196) в двоичную систему счисления: 196 = 128 + 64 + 4
Получается 196 (10) = 11000100 (2)
Переведем 224 в двоичную систему счисления: 224 = 128 + 64 +32
Получается 224 (10) = 11100000 (2)
Теперь нам нужно умножить двоичные представления чисел 196 и 224:
11000100
11100000
11000000(2)
Переведем 11000000(2) в десятичную систему счисления = 128+64 = 192
ответ: 12.16.192.0
2) В результате умножения ip и маски первые 2 байта останутся теми же, что в ip, а последний байт станет равен 0
Что мы сейчас имеем: Адрес сети - 146.212.x.0
Найдем x:
Переведем 3 байт (200) в двоичную систему счисления: 200 = 128 + 64 +8
Получается 200 (10) = 11001000 (2)
Переведем 240 в двоичную систему счисления: 240 = 128 + 64 +32 +16
Получается 240 (10) = 11110000 (2)
Теперь нам нужно умножить двоичные представления чисел 200 и 240:
11001000
11110000
11000000 (2)
Переведем 11000000(2) в десятичную систему счисления = 128+64 = 192
ответ: 146.212.192.0
const nmax=100; var a: array[1..nmax,1..nmax] of integer; i,j,m,n,min,max,i_max,j_max,i_min,j_min,tmp: integer; begin randomize; write('Введите размеры массива m, n: '); readln(m,n); writeln('Исходная матрица:'); for i:=1 to m do begin for j:=1 to n do begin a[i,j]:=random(99)+1; write(a[i,j]:4); end; writeln; end; writeln; min:=a[1,1]; max:=a[1,1]; i_min:=1; j_min:=1; i_max:=1; j_max:=1; for i:=1 to m do for j:=1 to n do begin if a[i,j]>max then begin max:=a[i,j]; i_max:=i; j_max:=j; end; if a[i,j]<min then begin min:=a[i,j]; i_min:=i; j_min:=j; end; end; writeln('Максимальный элемент: ',max,'[',i_max,',',j_max,']'); writeln('Минимальный элемент: ',min,'[',i_min,',',j_min,']'); tmp:=a[i_min,j_min]; a[i_min,j_min]:=a[i_max,j_max]; a[i_max,j_max]:=tmp; writeln('Полученная матрица:'); for i:=1 to m do begin for j:=1 to n do write(a[i,j]:4); writeln; end; readln; end.