В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lanceva3
lanceva3
25.05.2021 02:31 •  Информатика

1. напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последова¬тельность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число — сумму чисел, кратных 3 и не кратных 6, встречающихся с последовательности. пример работы программы: входные данные выходные данные 12 1 15 30 4 2 0

Показать ответ
Ответ:
мурад2008
мурад2008
21.09.2020 23:21
Var
a, n: integer;
begin
n:=0;
repeat
readln(a);
if (a mod 3 = 0) and (a mod 6 <> 0) then
inc(n, a);
until a = 0;
writeln(n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота