В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
sabinochka1709
sabinochka1709
02.07.2020 01:53 •  Информатика

1. напишите программу, которая находит максимальный и минимальный из чётных положи- тельных элементов массива. если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом. 2. введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих максимальное значение. 3. найдите за один проход по массиву три его различных элемента, которые меньше всех ос- тальных («три минимума»). 4. *заполните массив случайными числами в диапазоне 10..12 и найдите длину самой длинной последовательности стоящих рядом одинаковых элементов на питоне ! )

Показать ответ
Ответ:
Mihael13
Mihael13
08.10.2020 12:55
задача 1.
a=input().split()

f=-1

for i in range(len(a)):

    if int(a[i])>0 and int(a[i])%2==0:

        if f==-1:

            min1=int(a[i])

            max1=int(a[i])

            f=1

        elif int(a[i])>max1:

            max1=int(a[i])

        elif int(a[i])<min1:

            min1=int(a[i])

if f==-1:

    print('not solution')

else:

    print('max=',end='')

    print(max1)

    print('min=',end='')

    print(min1)

задача 2.

a=input().split()

k=0

max1=float(a[0])

for i in range(len(a)):

    if float(a[i])==max1:

        k+=1

    elif float(a[i])>max1:

        k=1

        max1=float(a[i])

print(k)

задача 3.

a=input().split()

min1=float(a[0])

min2=float(a[0])

min3=float(a[0])

for i in range(len(a)):

    if float(a[i])<min1:

        min3=min2

        min2=min1

        min1=float(a[i])

    elif float(a[i])<min2:

        min3=min2

        min2=float(a[i])

    elif float(a[i])<min3:

        min3=float(a[i])

print(min1)

print(min2)

print(min3)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота