1. Напишите программу, которая определяет среднее арифметическое двух чисел, если «a» положительное. И частное (a/b), если «a» отрицательное. Значения переменных должны вводиться с клавиатуры! Записать алгоритм на ШАЯ в этом файле с соблюдением правил написания в Кумире.
Составить структурную схему алгоритма и программу на языке Qbasic для вычисления f:
a=-1
b=4
f1(x) x<a
f2(x) a<=x<b
f3(x) x>=b
f1(x)=(a-x)/(2+3x^2) ; f2(x)=(a+b)x-x^2-ab; f3(x)=(b-x)/(5+x^2)
2.
Составить структурную схему алгоритма и программу на языке Qbasic
m=17
задание на программирование: составить программу вычисления m значений переменной Xk по рекурентной формуле
Xk=(далее выражение под корнем)2*(Xk-1)^2-7(Xk-1)+9
для k=1,2,3,...,m
3.
Составить структурную схему алгоритма и программу на языке Qbasic
a=4
b=12
Задание на программирование:
диффиренциал от a до b x^2*bx
4.
Составить блок схему алгоритма и программу на языке Qbasic при решении диффиренциального уравнения методом Эйлера:
(dy/dt)*2y+t=0
при y0=25; t0=0; tk=30; n=30
5.
Составить программу для вычисления основных статистических показателей выработки 2^x попарносвязанный значени x и y. РАсчитать основные статистические показатели для выработки:
x y
23 8
21 9
20 10
7 18
2 1
13 6
uses crt;
var a:array[1..11] of integer;
i,j,s,k:integer;
begin
writeln('Исходный массив: ');
for i:=1 to 10 do begin
a[i]:=random(5);
write(a[i]:4);
end;
s:=1; k:=0;
for i:=1 to 10 do begin
if a[i]=a[i+1] then s:=s+1;
if a[i]<>a[i+1] then begin if k<s then k:=s; s:=1; end;
end;
writeln;
writeln('Наибольшая последовательность одинаковых элементов: ',k);write(k);
end.
Массив состоит из 10 чисел (в описании максимум чисел должен быть на 1 больше, чем по факту, поэтому там 11). Числа в массиве задаются случайно в пределах от нуля до 5 (не включая 5).