В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lidok575
lidok575
20.02.2020 05:34 •  Информатика

1)Напишите программу, которая переводит цифровую систему отметок в словесную. Например если пользователь ввел оценку "5", на экран выводится словесная отметка "Пятерка" 2)Напишите альтернативную программу с применением оператора if для 1-ой задачи

Показать ответ
Ответ:
JadenGirl
JadenGirl
21.03.2021 13:56

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

case i of  

1: writeln('Единица');  

2: writeln('Двойка');  

3: writeln('Тройка');  

4: writeln('Четверка');  

5: writeln('Пятерка');  

else writeln('Нет такой оценки');  

end;  

readln;  

end.

Альтернативная задача

var i:integer;  

begin  

writeln('Введите оценку'); readln(i);  

if i = 1 then writeln('Единица')

else if i = 2 then writeln('Двойка')

else if i = 3 then writeln('Тройка')

else if i = 4 then writeln('Четверка')

else if i = 5 then writeln('Пятерка')

else writeln('Нет такой оценки');    

readln;  

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота