1) Напишите программу, которая с цикла подсчитывает сумму всех четных чисел от 5 до 25. Можете подсказать, где здесь ошибка? #include
using namespace std;
void chislo (int i, int summa=0)
{
if (i%2==0)
{
summa=summa+i;
}
}
int main ()
{
int i=5; i<=25; i++;
int summa;
cout<<"summa vseh chetnih chisel="< return 0;
}
var
a,b,c,d,e:byte;
k:integer;
begin
k:=0;
for a:=1 to 9 do begin
for b:=0 to 9 do
if b<>a then begin
for c:=0 to 9 do
if (c<>a) and (c<>b) then begin
for d:=0 to 9 do
if (d<>a) and (d<>b) and (d<>c) then begin
e:=0;
repeat
if a*c-c*e=a-b+c+d+e then Inc(k);
e:=e+2
until e<9
end
end
end
end;
Writeln(k)
end.
Тестовое решение:
190
2. Текст программы на языке Python
import math
a=float(input("Введите длину большего основания а: "))
b=float(input("Введите длину меньшего основания b: "))
alpha=float(input("Введите угол при большем основании в градусах: "))
alphar=alpha*math.pi/180
print("Площадь трапеции равна ",(a**2-b**2)/4*math.tan(alphar))
3. Тестовое решение
Python 3.4.2 (v3.4.2:ab2c023a9432, Oct 6 2014, 22:15:05) [MSC v.1600 32 bit (Intel)] on win32
Type "copyright", "credits" or "license()" for more information.
>>> ================================ RESTART ================================
>>>
Введите длину большего основания а: 20
Введите длину меньшего основания b: 10
Введите угол при большем основании в градусах: 40
Площадь трапеции равна 62.932472338295995
>>>