В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Armatod
Armatod
06.05.2021 02:24 •  Информатика

1) напишите программу, которая считает количество чётных цифр введённого числа. 2) напишите программу, которая считает сумму цифр введённого числа. все для c++ хорошо если через цикл с условиями

Показать ответ
Ответ:
Egor4ik42
Egor4ik42
08.10.2020 02:29
#include <iostream>
using namespace std;
int main()
{
     int val = 253;
     int sum = 0;
     int tmp = 0;
     int c   = 0;
     while (val) {
         tmp = val % 10;
         if (!(tmp % 2)) {
             ++c;
         }
         sum += tmp;
         val /= 10;
     }
     cout << "Res = " << sum << endl;
     cout << "Count = " << c << endl;
     system("pause");
     return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота