1. Напишите программу, которая считывает три числа и выводит Их сумму и
произведение. Каждое число записано в
отдельной строке.
2. Ввести целое число. Если оно является
положительным, то прибавить к нему 1; в
противном случае вычесть из него 2.
Вывести полученное число.
3.С цикла for вывести все целые
числа от 10 до 100
4. Вывести на экран кубы всех целых чисел
от 1 до 10. Цикл While
5.Создать список из десяти элементов.
Заполнить его случайными числами.
Вывести этот список. Вывести наибольший
Элемент списка.
#include <iostream>
using namespace std;
int main()
{
int a, b, c;
int amount = 0;
cin >> a >> b >> c;
if (a > 0)
{
amount += a;
}
if (b > 0)
{
amount += b;
}
if (c > 0)
{
amount += c;
}
cout << amount;
}
Объяснение:
#include <iostream> // Библиотека ввода - вывода
using namespace std; // Пространство имен
int main()
{
int a, b, c; // Создание целочисленных переменных a, b, c
int amount = 0; // Создание целочисленной переменной amount, которая будет хранить сумму положительных чисел. Значение переменной = 0
cin >> a >> b >> c; // Ввод с клавиатуры значений переменных a, b, c
if (a > 0) // Если значение переменной a > 0
{
amount += a; // К значению переменной amount прибавляем значение переменной a
}
if (b > 0) // Если значение переменной b > 0
{
amount += b; // К значению переменной amount прибавляем значение переменной b
}
if (c > 0) // Если значение переменной b > 0
{
amount += c; // К значению переменной amount прибавляем значение переменной c
}
cout << amount; // Вывод значения переменной amount
}
О, наконец освободился этот слот, ну, в общем, смотри как надо было эту задачу решать:
#include <iostream>
#include <vector>
#include <set>
#define ll long long
using namespace std;
signed main() {
ll n;
cin >> n;
vector<pair<ll,ll>> a(n);
vector<ll> pref(n,0),d(n,0),ans(n,0);
set<ll> s;
for(ll i = 0; i < n; i++){
cin >> a[i].first;
a[i].second = i;
s.insert(a[i].first);
if(i == 0)
pref[i] = a[i].first;
else
pref[i] = pref[i-1] + a[i].first;
d[i] = s.size();
}
if(d[n-1] > 1 || n == 1)
ans[a[n-1].second] = 1;
for(ll i = n - 2; i >= 0; i--){
if(pref[i] > a[i + 1].first && ans[a[i+1].second] == 1 && d[i] > 1)
ans[a[i].second] = 1;
}
for(ll i = 0; i < n; i++)
cout << ans[i] << " ";
}