В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ellis2034
Ellis2034
16.03.2021 00:31 •  Информатика

1.напишите программу, которая вводит два вещественных числа, x и y , и вычисляет значение x^y . 2.напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) . только на с++.

Показать ответ
Ответ:
Мейдей
Мейдей
31.03.2021 23:08
1)От 100 до 900 существует 801 число, для представления 801 различных чисел нужно 10 бит, 2 в 10-й степени =1024, а 2 в 9-й степени только 512. 
128х5х10=6400 бит=800 байт
2)Известно, что с бит можно закодировать 2N различных чисел. Поскольку 26 < 119 < 27 и для каждого спортсмена число бит одинаково, то для записи каждого из 119 номеров необходимо 7 бит памяти. Поскольку промежуточный финиш велосипедистов, то информационный объем сообщения составит 70*7 бит=490 бит.
7)Решение: N = 10 х 5 + 4 х 8 = 82        N = 2i  = 128         i = 7ответ: 7 бит
10)бщее количество ключей на всех уровнях 16*8=128 (чет много=)) 
Нам надо найти, в какую степень надо возвести 2, чтобы получить 128. 
2^x=128 
x=7 
Вот собственно и ответ. 7 бит

Все, что смогла :)
0,0(0 оценок)
Ответ:
Dashuli4ka2001
Dashuli4ka2001
13.07.2022 08:41
Var x, i, h1, h2, h3, h4, h5, h6, s1, s2: integer;
begin
       readln (x);
       h1 := x div 100000;
       h2 := x mod 100000 div 10000; 
       h3 := x mod 10000 div 1000; 
       h4 := x mod 1000 div 100; 
       h5 := x mod 100 div 10; 
       h6 := x mod 10; 
       s1 := h1 + h2 + h3; 
       s2 := h4 + h5 + h6; 
       if (s1 = s2) then writeln('Счастливый') 
                      else writeln('Несчастный:)');
        readln;
end.

Вот, ошибка в целочисленном делении) Советую такое на листочке расписывать: 123321 и обводить что нужно взять, что в каком порядке откидывать...)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота