В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
cozycoat1
cozycoat1
24.01.2022 03:52 •  Информатика

1. напишите программу, которая вводит трехзначное число и разбивает его на цифры. например, при вводе числа 123 программа должна вывести 1, 2, 3. 2. напишите программу, которая вводит возраст человека (число, не превосходящее 120) и выводит на экран этот возраст со словом «»год, «года» , «лет» . например «21 год», «22 года», «15 лет»

Показать ответ
Ответ:
romanres7ov
romanres7ov
06.07.2020 23:50
1 задача
program proga;
var st,st2:string;
i:Integer;
begin
writeln('Введите число');
readln(st);
for i:=1 to length(st) do begin
st2:=st[i];
write(st2,' ');
end;
end.
2 задача
program proga2;
var st,st2:string;
i,a:Integer;
begin
writeln('Введите возраст');
readln(a);
if a>120 then
writeln('Неверные данные');
if a=1 then
writeln(a,' год');
if (a>1) and (a<5) then
writeln(a,' года');
if((a mod 10 = 1) and (a div 10 <> 0 or 11 )) then writeln(a,' год');
if (a>=5) and (a mod 10 <> 2 or 3 or 4)and (a div 10 <> 10) then
writeln(a,' лет');
if (a<=5) and (a mod 10 = 2 or 3 or 4)and (a div 10 = 10) then writeln(a,' года ');
if(a>104) and (a<110)then writeln(a,' лет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота