В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
саидолим
саидолим
22.03.2020 18:46 •  Информатика

1.
напишите программу которая заменяет во всей строке одну последовательность символов на другую
введите строку:
(x > y) and (y < x) and (z > y) and (z < > 5)
что менаем : and
чем заменяем : &
результат
(x > y) & (y < x) & (z > y) & (z < > 5)
2.
напишите программу которая вычисляет сумму трех чисел в форме символьной строки. все числа целые
пример
введите выражение
12+3+45
ответ
60
3.
ввести с клавиатуры символьную строку и определить сколько в ней слов. словом считается последовательности непробельных символов отделенная с двух сторон проблемами(или стоящая с краю строки). слова могут быть разделены несколькими пробелами в начале и в конце строки тоже могут быть пробелы
пример
введите строку
вася пошёл гулять
найдено слов : 3

Показать ответ
Ответ:
kzifi
kzifi
03.09.2020 09:02

PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018

Внимание! Если программа не работает, обновите версию!

begin

var s:string; Writeln('Введите строку:'); Readln(s);

var s1:=ReadlnString('Что меняем:');

var s2:=ReadlnString('Чем заменить:');

s:=s.Replace(s1,s2);

Writeln('Результат'); Writeln(s)

end.

Пример

Введите строку:

(X > 0) and (Y < X) and (Z > Y) and (Z <> 5)

Что меняем: and

Чем заменить: &

Результат

(X > 0) & (Y < X) & (Z > Y) & (Z <> 5)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота