В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ggggeorgiyggg
ggggeorgiyggg
09.04.2020 08:32 •  Информатика

1)Напишите программу, которая заполняет матрицу из N строк и M столбцов нулями и единицами в шахматном порядке.
2)Напишите программу, которая заполняет матрицу из N строк и N столбцов нулями и единицами так, что все элементы выше главной диагонали равны нулю, а остальные – единице.

3)Напишите программу, которая заполняет матрицу из N строк и N столбцов нулями и единицами так, что все элементы выше побочной диагонали равны нулю, а остальные – единице.

Показать ответ
Ответ:
Nactyxa2003
Nactyxa2003
29.03.2021 09:31

N = int(input('Введите N (строки): '))

M = int(input('Введите M (столбцы): '))

array_1 = []

array_2 = []

array_3 = []

el = 0

for i in range(N):

   a = []

   if M % 2 == 0 and i > 0:

       if el == 0:

           el = 1

       else:

           el = 0

   for _ in range(M):

       a.append(el)

       if el == 0:

           el = 1

       else:

           el = 0

   array_1.append(a)

print('Задание 1.')

for row in array_1:

   for el in row:

       print(el, end = ' ')

   print()

for i in range(N):

   a = []

   for j in range(N):

       if j > i:

           a.append(0)

       else:

           a.append(1)

   array_2.append(a)

print()

print('Задание 2.')

for row in array_2:

   for el in row:

       print(el, end = ' ')

   print()

           

for i in range(N):

   a = []

   for j in range(N):

       if j < N - i - 1:

           a.append(0)

       else:

           a.append(1)

   array_3.append(a)

print()

print('Задание 3.')

for row in array_3:

   for el in row:

       print(el, end = ' ')

   print()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота