1) Напишите программу (на питоне), которая сортирует положительные элементы массива в порядке убывания, а отрицательные элементы в порядке возрастания. Алгоритм сортировки и его сложность на Ваше
усмотрение. Исходный массив вводится с клавиатуры. Отсортированный массив выводится на
экран.
x, y: array[1..100] of integer;
i, n, k: integer;
min, max: integer;
begin
{ввод массива}
write('n = ');
readln(n);
writeln('Данные массива:');
for i := 1 to n do
begin
readln(x[i]);
end;
writeln();
{минимум и максимум}
max := x[1];
min := x[1];
for i := 1 to n do
begin
if max < x[i] then max := x[i];
if min > x[i] then min := x[i];
end;
writeln('max = ', max);
writeln('min = ', min);
writeln('avg = ', (max + min) / 2);
max := (max + min) / 2;
k := 0;
for i := 1 to n do
begin
if x[i] >= max then begin
k := k + 1;
y[k] := x[i];
write(y[k], ' ');
end;
end;
end.
Это устройство или система выполнять особые операции, а также вычисления.
2.Что такое Операционная Система(ОС)?
Это комплекс взаимосвязанных программ, предназначенных для управления компьютером, операциями и также управления ресурсов.Есть 3 особо популярной ОС, это Windows, Linux, Mac.
3.Что такое материнская плата?
Это сложная многослойная печатная плата, являющаяся основой построения вычислительной системы.
4.Что такое видеокарта?
Это устройство, преобразующее графический образ, хранящийся как содержимое памяти компьютера, в форму, пригодную для дальнейшего вывода на экран монитора.
5.Что такое процессор?
Это "мозг" компьютера, тоесть это устройство, которое обрабатывать программный код определяющее основные функции компьютера по обработке информации.
6.Что такое Оперативная Память?(Основное Запоминающийся Устройство, в сокр. ОЗУ)
Это память, часть системы памяти ЭВМ, в которую процессор может обратиться за одну операцию. Предназначена для временного хранения данных и команд, необходимых процессору для выполнения им операций. Оперативная память передаёт процессору данные непосредственно, либо через кеш-память. Каждая ячейка оперативной памяти имеет свой индивидуальный адрес.7.Что такое Жёсткий Диск?
Это основное хранилище информации на твоем компьютере, которую можно изменять, создавать и т.п