1) Напишите программу, возводящую число во 2-ю и 3-ю степень это только первое. Еще 3 скину, они простые
Поставьте разделитель между заданиями. В качестве разделителя просто фразу в консоль выведите, например "1е задание", "2е задание"и т.д.
2) Напишите программу, решающее любое сложное математическое выражение. Результат само собой в консоль
3) Создайте переменные ВСЕХ типов, приведенных на протяжении двух уроков. Присвойте им значения, соответствующие их типу. Выведите каждую переменную в консоль
var n,a,s,i:integer;
begin
write('n = ');
readln(n);
writeln('Введите ',n,' чисел:');
s:=0;
for i:=1 to n do
begin
read(a);
s:=s+a;
end;
writeln('s = ',s);
end.
2)var n,a,s,i:integer;
begin
write('n = ');
readln(n);
writeln('Введите ',n,' чисел:');
s:=0;
i:=0;
repeat
i:=i+1;
read(a);
s:=s+a;
until i=n;
writeln('s = ',s);
end.
3)
var n,a,s,i:integer;
begin
write('n = ');
readln(n);
writeln('Введите ',n,' чисел:');
s:=0;
i:=0;
while i<n do
begin
i:=i+1;
read(a);
s:=s+a;
end;
writeln('s = ',s);
end.
Пример:
n = 5
Введите 5 чисел:
8 2 9 6 4
s = 29
Можно посылать текст
Можно посылать вложение типа фотографии, если хватает места/веса
Указывается адрес получателя и адрес отправителя
Может быть не доставлено из за неверного адреса или из за технических сбоев.
Можно перенаправить письмо
Дата прохождения через почтовую службу может служить подтверждением времени в различных спорах и разбирательствах
Возможно использовать шифрование
Плюсы бумажной почты
Письмо и вложения реальны и не требуют спец средств для прочтения
Очень разнообразные доставки - голубиная почта, курьерская почта и тд
Количество спама обычно меньше чем в электронной почте
Можно послать письмо без указания обратного адреса
Плюсы электронной почты
Скорость доставки
Бесплатно
Значительно легче шифровать/разшифровать, чем бумажную
Возможность получить подтверждение о получении, прочтении
Возможность настройки автоматического ответа (например если в отпуске)
Возможность отослать одно письмо множеству получателей
Копия отправленного письма остается у отправителя
Получить почту можно из любой точки интернета, а не в определенном месте (почтовый ящик)
Можно иметь множество электронных почтовых ящиков
Думаю этого хватит