1) Напишите программу, вычисляющую значение функции f(x)= {-5 при x<0 {0 при x=0 {5 при x>0 2) Напишите программу, нахождения максимального из пяти чисел
в) var b,c : real; (чаще всего используется при нахождении вещественных чисел)
var a: integer; (чаще всего используется при нахождении вещественных чисел)
г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения) 3)
PROGRAM PR1;
var w,s,b: integer;
BEGIN
READLN (S, B);
w:= ((12*s) + (26*b));
WRITELN (W);
end. 4) Запишите на языке Паскаль следующие условия: а) f >105 ; б) a<184 ; в) w<>181; г) z>0; д) z<=d; е) (y*x)>=(d+w); ж) (w-d)<88; з) f>=1; 5. Запишите на языке Паскаль команду ветвления для решения следующей задачи:
а) if a<> 21 then a:=a+28 else a:=a-51; б) if a mod 2=0 then a:=a+5 else a:=a-12;
6. Запишите на языке Паскаль команду цикла для решения следующей задачи: а) PROGRAM PR1; var j,p: integer; BEGIN j:=1; p:=0; While j>=66 do BEGIN p:= p*j; j:=j+1: WRITELN (‘произведение чисел = ‘, p); end. б)
в) var b,c : real; (чаще всего используется при нахождении вещественных чисел)
var a: integer; (чаще всего используется при нахождении вещественных чисел)
г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения) 3)
PROGRAM PR1;
var w,s,b: integer;
BEGIN
READLN (S, B);
w:= ((12*s) + (26*b));
WRITELN (W);
end. 4) Запишите на языке Паскаль следующие условия: а) f >105 ; б) a<184 ; в) w<>181; г) z>0; д) z<=d; е) (y*x)>=(d+w); ж) (w-d)<88; з) f>=1; 5. Запишите на языке Паскаль команду ветвления для решения следующей задачи:
а) if a<> 21 then a:=a+28 else a:=a-51; б) if a mod 2=0 then a:=a+5 else a:=a-12;
6. Запишите на языке Паскаль команду цикла для решения следующей задачи: а) PROGRAM PR1; var j,p: integer; BEGIN j:=1; p:=0; While j>=66 do BEGIN p:= p*j; j:=j+1: WRITELN (‘произведение чисел = ‘, p); end. б)
1) а:=b(13)+a(-2)*3=13+(-2*3)=13-6=7
2) a) readln(а); readln(х);
б) writeln(z)
в) var b,c : real; (чаще всего используется при нахождении вещественных чисел)
var a: integer; (чаще всего используется при нахождении вещественных чисел)
г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения)3)
PROGRAM PR1;
var w,s,b: integer;
BEGIN
READLN (S, B);
w:= ((12*s) + (26*b));
WRITELN (W);
end.
4) Запишите на языке Паскаль следующие условия:
а) f >105 ;
б) a<184 ;
в) w<>181;
г) z>0;
д) z<=d;
е) (y*x)>=(d+w);
ж) (w-d)<88;
з) f>=1;
5. Запишите на языке Паскаль команду ветвления для решения следующей задачи:
а) if a<> 21 then a:=a+28 else a:=a-51;
б) if a mod 2=0 then a:=a+5 else a:=a-12;
6. Запишите на языке Паскаль команду цикла для решения следующей задачи:
а) PROGRAM PR1;
var j,p: integer;
BEGIN j:=1; p:=0;
While j>=66 do BEGIN p:= p*j; j:=j+1:
WRITELN (‘произведение чисел = ‘, p);
end.
б)
PROGRAM PR1;
var n:integer;
begin
for n:=1 to 7 do
writeln('trud');
end.
1) а:=b(13)+a(-2)*3=13+(-2*3)=13-6=7
2) a) readln(а); readln(х);
б) writeln(z)
в) var b,c : real; (чаще всего используется при нахождении вещественных чисел)
var a: integer; (чаще всего используется при нахождении вещественных чисел)
г) if d = a(число, которому нужно прировнять, этот фрагмент цикла(если…,то ..иначе)) then d:=d+20; д) z := x + y; ( : = это знак присвоения)3)
PROGRAM PR1;
var w,s,b: integer;
BEGIN
READLN (S, B);
w:= ((12*s) + (26*b));
WRITELN (W);
end.
4) Запишите на языке Паскаль следующие условия:
а) f >105 ;
б) a<184 ;
в) w<>181;
г) z>0;
д) z<=d;
е) (y*x)>=(d+w);
ж) (w-d)<88;
з) f>=1;
5. Запишите на языке Паскаль команду ветвления для решения следующей задачи:
а) if a<> 21 then a:=a+28 else a:=a-51;
б) if a mod 2=0 then a:=a+5 else a:=a-12;
6. Запишите на языке Паскаль команду цикла для решения следующей задачи:
а) PROGRAM PR1;
var j,p: integer;
BEGIN j:=1; p:=0;
While j>=66 do BEGIN p:= p*j; j:=j+1:
WRITELN (‘произведение чисел = ‘, p);
end.
б)
PROGRAM PR1;
var n:integer;
begin
for n:=1 to 7 do
writeln('trud');
end.