В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LerkaKsuphaMey
LerkaKsuphaMey
10.10.2021 02:04 •  Информатика

1. найти те элементы массива, которые равны сумме двух своих соседей. первый и последний элемент имеют только по одному соседу, поэтому искомыми быть не могут. на вход программе сначало подается значение n< =100 – количество элементов в массиве. в следующей строке расположены сами элементы массива – целые числа, по модулю не превосходящие 10000. выдайте значения искомых элементов массива в том же порядке, в каком они располагались во входных данных. 2. на вход программе подается последовательность чисел от 1 до 9, заканчивающаяся нулем. всего будет введено не более 100000 чисел. подсчитайте в этой последовательности количество единиц, количество двоек, количество троек и т.д. и выдайте результат. в выходных данных всегда должно быть 9 чисел. 3. текст на языке запишите в массив a[1..1000] of char. помимо букв в нем могут встречаться пробелы и знаки препинания. в массиве b [‘a’ ..’z’’] of integer получите сведения о том, сколько и каких букв встречается в этом тексте. при подсчете строчные и прописные буквы не различать. на вход программе подается значение n< =1000 – количество символов в тексте. в следующей строке входных данных расположены сами символы (без разделителей). выдайте 26 чисел – значения элементов массива b. пример входные данные выходные данные 12 hello world! 0 0 0 1 1 0 0 1 0 0 0 3 0 0 2 0 0 1 0 0 0 0 1 0 0 0 4. подсчитайте за один проход, сколько его элементов равны максимальному элементу. на вход программе сначала подается значение n< =100 – количество элементов в массиве. в следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. выдайте количество искомых элементов массива. 5. в массиве, заполненным произвольными целыми числами, найдите два числа, произведение которых максимально. вложенные циклы не используйте. на вход программе сначала подается значение n< =10000 – количество элементов в массиве. в следующей строке входных данных расположены сами элементы – целые числа, по модулю непревосходящие 30000. выдайте два искомых числа в порядке неубывания. 6. на вход программе сначала подается значение n< =100 – количество элементов в массиве. в следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. распечатайте только те значения элементов массива, которые встречаются в нем ровно один раз. элементы следует распечатывать в том порядке, в котором они встречаются в массиве. решите любые две

Показать ответ
Ответ:
grenika
grenika
15.07.2020 17:59
Задача 1
var
  a:array [1..100] of integer;
  i,n:integer;
begin
  writeln('Введите n <=100');
  readln(n);
  writeln('Введите массив');
  for i:=1 to n do
  readln(a[i]);
  writeln('Массив');
  for i:=1 to n do
  write(a[i], ' ');
  writeln;
  writeln('Элементы равные сумме двух соседей:');
  for i:=2 to (n-1) do
  if a[i]=(a[i-1]+a[i+1]) then write(a[i],' ');
  writeln;   
end.

задача 5
var
  a:array [1..10000] of integer;
  i,n, mx1, mx2:integer;
begin
  writeln('Введите n <=10000');
  readln(n);
  writeln('Введите массив');
  for i:=1 to n do
  readln(a[i]);
  writeln('Массив');
  for i:=1 to n do
  write(a[i], ' ');
  writeln;
  mx1:=1;
  for i:=2 to n do
  if a[i]>a[mx1] then mx1:=i;
  if mx1=1 then mx2:=2 else mx2:=1;
  for i:=1 to n do
  if (a[i]>a[mx2])and(i<>mx1) then mx2:=i;
  writeln('Два числа произведение которых максимально: ',a[mx2],' ',a[mx1]);   
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота