1) Объем массива 30. Заполняем массив случайными числами от 100 до 500. 2) Вектор {хі}, і=1,…20 вычислите количество компонентов, лежащих в заданном интервале [0,1].
3) а1…аn даны целых цифры. Найти: min(a2,a4,…) + max( a1,a3…).
4) В массиве целых чисел найдите сумму элементов, разделенных как на 3, так и на 6.
написать программу на языке Си.
Служби Інтернету
За своєю архітектурою Інтернет — це клієнт-серверна мережа, тобто в ній є сервери, що підтримують роботу певних служб, і клієнти, які користуються цими службами. Найвідомішими та найпоширенішими службами Інтернету вважаються Всесвітня павутина й електронна пошта.
Інтернет також є платформою, на основі якої будуються файлообмінні мережі й електронні платіжні системи, розвиваютьсяінтернет-телебачення та інтернет-телефонія.
Кожна служба Інтернету має власні протоколи, що застосовуються для взаємодії між користувачем (клієнтською прикладною програмою) та службою.
Служба Інтернету — це набір послуг, які надаються клієнтам програмним забезпеченням серверів Інтернету з використанням певних мережних протоколів.
Зараз ви ознайомитесь з основними службами Інтернету та дізнаєтесь, які можливості вони надають користувачам.
До служб Інтернету відносяться:
Веб Веб-форуми Блоги Вікі-проекти (в тому числі й Вікіпедія) Інтернет-магазини Інтернет-аукціони Електронна пошта та списки розсилки Групи новин (в основному, Usenet) Файлообмінні мережі Електронні платіжні системи Інтернет-радіо Інтернет-телебачення IP-телефонія Системи обміну повідомленнями FTP-сервери IRCbegin
var a:=MatrixRandom(7,7,0,9);
var k:=0;
for var i:=0 to 6 do begin
for var j:=0 to 6 do begin
Write(a[i,j]:3);
if a[i,j] in [1..5] then Inc(k)
end;
Writeln
end;
Writeln('Кол-во элементов на [1,5]: ',k)
end.
Тестовое решение:
2 1 7 3 3 2 7
9 2 9 2 0 5 5
4 2 6 9 4 6 0
1 0 3 5 4 5 9
6 3 6 0 2 0 8
0 8 4 3 2 1 8
6 0 4 4 5 4 0
Кол-во элементов на [1,5]: 27
Вариант "совсем для школы"
const
n=7;
var
a:array[1..n,1..n] of integer;
i,j,k:integer;
begin
Randomize;
k:=0;
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=Random(10);
Write(a[i,j]:3);
if a[i,j] in [1..5] then Inc(k)
end;
Writeln
end;
Writeln('Кол-во элементов на [1,5]: ',k)
end.