1) опишите на языке или одном из языков программирования алгоритм подсчета максималното
количества подряд идущих отрицательных элементов в целочисленном массиве длины 30.
2) дан целочисленный массив из 30 элементов. элементы массива могут принимать целочисленные
значение значения от -20 до 20 - сведения о температуре за каждый день ноября. опишите на
языке или на одном из языков программирования алгоритм, который находит и выводит максимальную
температуру среди дней, когда были заморозки (температура опускалась ниже нуля). гарантируется,
что хотя бы один день в ноябре была отрицательная температура.
исходные данные объявлены так, как показано ниже. запрещается использовать переменные, не
описанные ниже, но разрешается не использовать часть из них.
паскаль
естественный язык
const n=30;
объявляем массив а из 30 элементов.
var a: array [1..n] of integer;
объявляем целочисленные переменные i, j,
i, j, max: integer;
begin
max. в цикле от 1 до 30 вводим элементы
for i: =1 to n do readln(a[i]); массива ас 1-го по 30-й.
end.
в качестве ответа вам необходимо фрагмент программы (или описание алгоритма на
естественном языке), который должен находиться на месте многоточия. вы можете записать решение
также на другом языке программирования (укажите название и используемую версию языка
программирования, например, borland pascal 7.0) или в виде блок-схемы. в этом случае вы должны
использовать те же самые исходные данные и переменные, какие были предложены в условии
(например, в образце, записанном на естественном языке).
3) опишите на языке или одном из языков программирования алгоритм вычисления среднего
арифметического элементов квадратной матрицы размером 5 на 5, стоящих на главной диагонали.
4) дан целочисленный массив из 30 элементов, все элементы которого – неотрицательные числа, не
превосходящие 1. опишите на языке или на одном из языков программирования
алгоритм, который находит и выводит минимальное трехзначное число, записанное в этом массиве.
если таких чисел нет, нужно вывести сообщение "таких чисел нет".
исходные данные объявлены так, как показано ниже. запрещается использовать переменные, не
описанные ниже, но разрешается не использовать часть из них.
паскаль
естественный язык
const n=30;
объявляем массив а из 30 элементов.
var a: array [1..n] of integer;
объявляем целочисленные переменные i, j,
i, j, min: integer;
begin
min. в цикле от 1 до 30 вводим элементы
for i: =1 to n do readln(a[i]); массива ас 1-го по 30-й.
end.
в качестве ответа вам необходимо фрагмент программы (или описание алгоритма на
естественном языке), который должен находиться на месте многоточия. вы можете записать решение
также на другом языке программирования (укажите название и используемую версию языка
программирования, например, borland pascal 7.0) или в виде блок-схемы. в этом случае вы должны
использовать те же самые исходные данные и переменные, какие были предложены в условии
(например, в образце, записанном на естественном языке).
Все слова/анаграммы, которые можно составить из слова "сканер"
Из "сканер" можно составить 58 слов из 2,3,4,5 букв.
Слова из 2 букв, составленные из комбинации "сканер" (12 слов):
ан ар ас ер ка кн кр на не нс ре се
Слова из 3 букв, составленные из комбинации "сканер" (22 слова):
акр аре арк аск ера кар кеа кен кер кнр нар нас нес рак рен рнк сак сан сен сер сна сне
Слова из 4 букв, составленные из комбинации "сканер" (13 слов):
акне енка каре керн крае кран крен раек река саек саке сена сера
Слова из 5 букв, составленные из комбинации "сканер" (11 слов):
аксен анкер аскер кенар нарек насек нерка серка серна скарн скена
Объяснение:
// Example program
#include <iostream>
#include <string>
int main()
{
int k[30];
for(int i = 0; i < 30; i ++) //заполняем случайными числами
k[i] = rand();
int min_sum = 999999999;
int num1, num2;
for(int i = 0; i < (30 - 1); i ++) //цикл поиска, i меняется от начала
//до предпоследнего элемента, чтобы не выйти
//за пределы при обращении к i + 1 элементу
{
int sum = k[i] + k[i+1];//очередная сумма
if(sum < min_sum) //сравниваем ее с текущим минимумом
{//если она меньше, то
min_sum = sum;//обновляем текущую сумму
num1 = i; num2 = i + 1;//обновляем номер
}
}
//на выходе из цикла в min_sum и num1 и num2 имеем самые минимальные номера
std::cout << "min_sum = " << min_sum << " nomer1 = " << num1 <<" nomer2 = " << num2;
}