1. Отметить
последовательность
действия алгоритма
«Программа на языке
Python»Из одного города в
другой Дамир ехал на
автомобиле со скоростью
90 км/ч, на обратном пути -
на автобусе со скоростью
60 км/ч. Найдите среднюю
скорость движения от
одного города в другой и
обратно, если длина пути
между этими городами 180
км/ч.
3,2,8,7,4,1,5,6,9,10
1,9,2,4,5,6,7,8,10,3
1,2,3,4,5,6,7,8,9,10
4,8,9,7,5,1,10,2,6,3
исходный код на языке программирования pascal
const n = 10;
var
a: array[1..n] of integer;
i: byte;
avrg: real;
sum: integer;
begin
randomize;
for i: =1 to n do a[i]: =random(50)+1;
sum : = 0;
for i: =1 to n do sum : = sum + a[i];
avrg : = sum/n;
// весь массив
for i: =1 to n do write(a[i]: 3);
writeln;
writeln('среднее арифм.: ',avrg: 4: 2);
// больше avrg
for i: =1 to n do if a[i]< avrg then write(a[i]: 3);
writeln;
end.
пример(ы) выполнения программы на языке pascal
13 23 45 2 9 28 47 30 18 12
среднее арифм.: 22.70
13 2 9 18 12
есть массив a из n чисел, к каждому числу массива жарасхан должен применить лишь одну операции
1) добавить к числу один
2) отнять от числа один
3) добавить к числу ноль
к каждому элементу массива нужно применить одну их трех операции так, чтоы после применения операций ко всем элементам массива, количество одинаковых чисел в массиве стало максимальным.
формат входных данных:
в первой строке входных данных дано одно целое число n - размер массива. во второй строке входных данных даны элемента массива a;
формат выходных данных:
выведите одно целое число - максимальное количество одинаковых чисел в массиве после применения операций.
пример:
входные данные:
7
3 1 4 1 5 9 2
выходные данные:
4
замечание: в первом тесте можно изменить массив в такой вид: 2,2,3,2,6,9,2