1. Отметьте условия, записанные на языке Python правильно.
1) a ≥ 0
2) x <= 3
3) x > 0 or y < 0
4) c ≠ 0
5) a =! b
6) -5 < a < 10
7) x > 0, y < 0
8) a > 10 и b < 5
9) x== 6
10) x = y = z
11) x <> 0
2. Дана программа на языке Python:
print ('Введите три числа: ')
a, b, c = map (float, input(). split ())
x = a
if b < x:
x = b
if c < x:
x = c
print ('x=', x)
Что будет выведено в результате работы программы при следующих входных данных?
а) 10 5 1
б) 10 5 7
в) 2 10 5
Постройте блок-схему, соответствующую программе.
3. Напишите программу, которая производит обмен значений переменных x и y, если x больше у
Пример входных данных
x>>5
y>>6
Пример выходных данных
x= 5
y= 6
** (* - любой из символов В или С)
*А*
ААА*АА*
АА*ААА*
А**
** (пока 6 вариантов)
Далее - аналогично:
**А
ААА*А*А
АА*АА*А
А*ААА*А
**А (ещё 5 вариантов)
ААА**АА
АА*А*АА
А*АА*АА
*ААА*АА (ещё 4 варианта)
АА**ААА
А*А*ААА
*АА*ААА (ещё 3 варианта)
А**
*А* (ещё 2)
** (ещё 1)
Итого: 6+5+4+3+2+1=21
Так как на месте * могут быть любые из 2 символов В или С, то это даст ещё по 4 варианта для каждого случая.
Можно здесь, конечно, комбинаторику вспомнить.
Итого: 21*4 = 84
ответ:ОБЪЯВЛЕНИЕ МАССИВА
Массивы в Паскале используются двух типов: одномерные и двумерные.
Определение одномерного массива в Паскале звучит так: одномерный массив — это определенное количество элементов, относящихся к одному и тому же типу данных, которые имеют одно имя, и каждый элемент имеет свой индекс — порядковый номер.
Описание массива в Паскале (объявление) и обращение к его элементам происходит следующим образом:
Описание массива в Паскале
Объявление массива
var dlina: array [1..3] of integer;
begin
dlina[1]:=500;
dlina[2]:=400;
dlina[3]:=150;
...
dlina — идентификатор (имя) массива;
для объявления используется служебное слово Array (в переводе с англ. «массив» или «набор»);
[1..3] — в квадратных скобках ставится номер (индекс) первого элемента, затем две точки и индекс последнего элемента массива, т.е. по сути, указывается количество элементов; количество элементов массива называется размерностью массива
of integer (с англ. «из целых чисел») — указывает, к какому типу относится массив, of здесь — служебное слово.
Объявить размер можно через константу:
размер массива через константу
ИНИЦИАЛИЗАЦИЯ МАССИВА
Кроме того, массив может быть сам константным, т.е. все его элементы в программе заранее определены. Описание такого массива выглядит следующим образом:
const a:array[1..4] of integer = (1, 3, 2, 5);
Заполнение последовательными числами:
заполнение массива
Результат:
A[1] = 8, A[2] = 9, A[3] = 10, ..., A[N] = A[N-1] + 1
Ввод с клавиатуры:
Пример: Рассмотрим, как происходит ввод массива в Паскале:
writeln ('введите кол-во элементов: ');
readln(n); {если кол-во заранее не известно, - запрашиваем его}
for i := 1 to n do begin
write('a[', i, ']=');
read(a[i]);
...
end;
...
Объяснение: