В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sacredand
sacredand
27.01.2021 05:46 •  Информатика

1.сформулировать ,решение которой содержало бы данный фрагмент.записать программу полностью. for i: =1 to 8 do begin b[i] : = a[i]*a[i]; write (b[i], ' ') end. 2.составить программу для решения . дан массив из 9 натуральных чисел.составить программу,которая проверяет,является ли каждый элемент массива нечетным числом.

Показать ответ
Ответ:
tim2003np0acpp
tim2003np0acpp
06.10.2020 00:25
1. Дан массив a, состоящий из 8 элементов. Получить массив b, в котором b[i] = a[i]*a[i] (1 <= i <=8).
var a,b:array[1..8] of integer;
i:integer;
begin
writeln('a:');
for i:=1 to 8 do
begin
 a[i] := random(10);
 write (a[i], ' ')
 end;
writeln;
writeln('b:');
for i:=1 to 8 do
 begin
 b[i] := a[i]*a[i];
 write (b[i], ' ')
 end;
end.

Пример:
a:
2 9 7 5 2 0 8 7
b:
4 81 49 25 4 0 64 49

2.
var a:array[1..9] of integer;
i:integer;
begin
writeln('a:');
for i:=1 to 9 do
begin
 a[i] := random(50)+10;
 write (a[i], ' ')
 end;
writeln;
for i:=1 to 9 do
 if a[i] mod 2 = 0
  then writeln(a[i], ' - четное число')
  else writeln(a[i], ' - нечетное число')
end.

Пример:
a:
55 51 18 35 33 56 15 56 47 
55 - нечетное число
51 - нечетное число
18 - четное число
35 - нечетное число
33 - нечетное число
56 - четное число
15 - нечетное число
56 - четное число
47 - нечетное число
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота