В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
lukycuk
lukycuk
01.11.2020 02:53 •  Информатика

1)Составить программу.

Элементы двумерного массива – случайные числа, лежащие в диапазоне [0,40].

Найти минимальный элемент в каждом столбце массива.
2)Впишите в тексты программ операторы так, чтобы в результате были получены расположенные напротив них матрицы

Показать ответ
Ответ:
ladyled
ladyled
23.04.2021 21:35

class Book:

   def __init__(self, title = None, author = None, year = None):

       self.title = title

       self.author = author

       self.year = year

   def display(self):

       text = ""

       

       if self.title != None: text = text + self.title[0:30] + " "

       if self.author != None: text = text + self.author[0:20] + " "

       if self.year != None: text = text + str(self.year)[0:5] + ""

       

       print(text)

       

book = Book('book', 'Author', 1234567)

book.display()

0,0(0 оценок)
Ответ:
danilgrekov20
danilgrekov20
12.12.2022 20:20
//Видимо, это одна задача, так как "изменения" во второй не указаны
//Pascal ABC.NET v3.1 сборка 1172

Const
 n=20;

Var
 ar:array[1..n] of integer;
 i:integer;
begin
 randomize;
 writeln('First array:');
  for i:=1 to n do
   begin
    ar[i]:=random(10)-3;
    write(ar[i]:4);
    if ar[i]>0 then ar[i]:=ar[i]*2 else ar[i]:=0;
   end;
 writeln;
 writeln('Final array:');
  for i:=1 to n do
   write(ar[i]:4);
end.

Пример работы программы:
First array:   2  -3   5   6  -3  -3   1  -2  -3   1   3  -3   4  -3   1  -1   6   6   2   3
Final array:   4   0  10  12   0   0   2   0   0   2   6   0   8   0   2   0  12  12   4   6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота