В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vovashkaruba
vovashkaruba
11.09.2021 07:19 •  Информатика

1.составить программу и алгоритм находящую сумму цифр трехзначного числа 2.составить программу и алгоритм находящую все простые делители заданного числа

Показать ответ
Ответ:
дан55566
дан55566
28.06.2020 15:46
Program gt;
var s,a,b,c,n:longint;
begin
read(n);
a:=n div 100;
b:=(n mod 100)div 10;
c:=n mod 10;
s:=a+b+c;
writeln(s);
end.
2)
program gt;
label 1;
var p,n,i,j:longint;
begin
read(n);
for i:=2 to n do
begin
if(n mod i=0)then begin
p:=round(sqrt(i));
for j:=2 to p do
begin
if(i mod j=0)then goto 1;
end;
writeln(i);
1:
end;
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота