В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
bnhgj4p08xdt
bnhgj4p08xdt
14.09.2021 10:31 •  Информатика

1. Составить программу, которая генерирует 10-значный код из букв, цифр и знаков пунктуации. 2. *Используя строковую функцию isnumber(), которая проверяет, есть ли в строке цифры, должно появляться сообщение, что пароль содержит цифры или нет ().

Показать ответ
Ответ:
annsamoilenko16
annsamoilenko16
15.09.2020 00:00

Код написал на Python:

Рандомная строка из букв, цифр и знаков пунктуации:

import random

chars = "0123456789r!'#$%&()*+,-./:;<=>[email protected][\]^_`{|}~"

len_chars = len(chars)

str_result = ""

for i in range(10):

   r_number = random.randint(0,len_chars)

   str_result = str_result + chars[r_number]

print(str_result)

Проверка на цифры в строке (если будете считать как новую задачу, то знайте, кусок кода взял из первой для генерации случайной строки):

import random

chars = "0123456789r!'#$%&()*+,-./:;<=>[email protected][\]^_`{|}~"

len_chars = len(chars)

str_result = ""

for i in range(10):

   r_number = random.randint(0,len_chars)

   str_result = str_result + chars[r_number]

print(str_result)

counter = 0

for i in range(10):

   if (i == 9):

       if (str_result[i].isnumeric() == False):

           print("There is no numbers in string")

   else:

       if (str_result[i].isnumeric() == True):

           print("There is at least one number in string")

           break

       else:

           continue

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота