№1. Составить программу, которая определяет номер строки и столбца элемента двумерного массива, значение которого больше 0, но меньше 2. Заполнить массив целыми случайными числами из диапазона от 0 до 30. №2. Составить программу, которая вычисляет количество положительных чисел среди 10 чисел, которые вводятся с клавиатуры.Выполнить 2 задания на языке C++ и на языке Python.
#include <iostream>
#include <ctime>
using namespace std;
int main()
{
srand ( time(NULL) );
int arr[10],i,k=0;
//Заполняешь массив
for (i=0;i<sizeof(arr)/sizeof(int);i++)
{
arr[i] = 1+rand()%10;
}
//Перебираешь массив
cout<<"Массив :";
for (int i=0; i<sizeof(arr)/sizeof(int);i++)
{
cout<<" "<<arr[i];
if (arr[i] % 2 == 0)
{
k++;
}
}
cout<<endl<<"Четных :"<<k;
return 0;
}
Объяснение:
много на самом деле. Например самый банальный. Перебираешь массив и проверяешь, если текущий элемент при делении на 2 дает в остатке 0 - значит четное. Значит прибавляешь счетчик (например, переменную a++). Иначе ничего не делаешь. В конце выводишь результат счетчика (a)