В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Лол1666
Лол1666
20.07.2021 14:35 •  Информатика

1. составить программу, которая создает нетипизированный файл из 100 чисел и выводит на экран k-ый элемент.

2. составить программу, которая создает копию элементов нетипизированного файла f и помещает в файл g.

3. составить программу, которая создает массив целых чисел и записывает его в нетипизированный файл, а также вычисляет среднее арифметическое элементов файла.

4. составить программу, которая создает массив целых чисел и записывает его в нетипизированный файл, а также вычисляет сумму элементов файла.

5. составить программу, которая создает массив целых чисел и записывает его в нетипизированный файл, а также вычисляет произведение элементов файла.

6. составить программу, которая создает массив целых чисел и записывает его в нетипизированный файл, а также вычисляет количество чётных элементов файла.

7. составить программу, которая создает массив целых чисел и записывает его в нетипизированный файл, а также вычисляет количество элементов меньше числа к файла.

8. составить программу, которая создает массив целых чисел и записывает его в нетипизированный файл, а также вычисляет среднее арифметическое элементов файла и сумму элементов меньше среднего арифметического.

Показать ответ
Ответ:
AzaGoo1
AzaGoo1
14.01.2022 09:04

#include <iostream>

 

using namespace std;

 

int main() {

   const char* s = "one two three four five six seven";

 

   const char* w = 0;

   int max_size = 0;

   int word_size = 0;

   for (int i = 0; s[i]; i++) {

       if (s[i] != ' ') {

           word_size++;;

       } else if ((s[i] == ' ') || !s[i + 1]) {

           if (word_size > max_size) {

               max_size = word_size;

               w = s + i - word_size;

           }

           word_size = 0;

       }

   }

   

   for (int i = 0; i < max_size; i++) {

       std::cout << w[i];

   }

   std::cout << "\n";

   

   return 0;

}

0,0(0 оценок)
Ответ:
kksa2001
kksa2001
23.05.2022 20:24

Сначала переводим числа 6 и 4 в 2-ную систему. Для этого делим всё время на 2 с остатком:

6 / 2 = 3 (остаток 0)

3 / 2 = 1 (остаток 1)

Выписываем последний результат деления (1) и все остатки, начиная с конца:

1 1 0

Таким образом:

6_{10} = 110_{2}

Аналогично:

4_{10} = 100_{2}

Умножаем: 110 х 100 = 11000

11000_{2} = 24_{10}

Тут действует такое же правило, что и для обычных десятичных чисел: чтобы умножить на 10, 100, 1000, 10000 и т.д., достаточно просто дописать справа столько нулей, сколько их есть в этом множителе.  А вобще умножение двоичных чисел выполняется точно так же, как и десятичных - если нужно, то в столбик. Двоичную "Таблицу умножения" очень легко выучить наизусть:

0 х 0 = 0

0 х 1 = 0

1 х 0 = 0

1 х 1 = 1

Когда при умножении в столбик мы складываем промежуточные результаты, правила тоже простые:

0 + 0 = 0

0 + 1 = 1

1 + 0 = 0

1 + 1 = 10

(смотри пример умножения на прикреплённом рисунке)



50 , умножьте числа 6 и 4 в двоичной системе. как это вообще делать? ( можете не спамить, все равно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота