В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kirill20060729
kirill20060729
25.02.2021 02:51 •  Информатика

1) Составить программу, которая запрашивает целое трёхзначное число и на экран выдаёт остаток от деления этого числа на 100. 2) Напишите программу нахождения минимального и максимального из 3-х чисел, введённых с клавиатуры. 3) Вычислить среднее арифметическое 3-х чисел, введенных с клавиатуры 4) Журавлики Петя, Катя и Сережа делают из бумаги журавликов. Вместе они сделали

Показать ответ
Ответ:
medusya
medusya
11.06.2022 19:56
// Напишите программу, которая в последовательности натуральных чисел определяет количество
//чисел, кратных 3. Программа получает на вход количество чисел в
//последовательности, а затем сами числа. В последовательности всегда имеется число,
//кратное 3. Количество чисел не превышает 100. Введённые числа не превышают 300.
//Программа должна вывести одно число - количество чисел, кратных 3.

Var  i,j,x  :word;
     n      :integer;
begin
  writeln('Введите количество цифр в последовательности');
  Readln (j);
  if j>100 then //Проверка накличество чисел в последовательности
      begin
        writeln ('По условия задачи цифр не должно быть более 100');
        writeln ('Введите количесво цифр еще раз');
        readln (j);
      end;
  for i:=1 to j do
  begin
    Writeln ('Введите ',i,' число');
    readln (n);
    if n>300 then //проверка максимального значения числа
      begin
        writeln ('Данное число не удовлетворяет условиям задачи (>300');
        writeln ('Введите его еще раз');
        readln (n);
      end;
      n:= n mod 3;
      if n=0 then x:=x+1;
      end;
   Writeln ('Количество чисел, кратных 3:');
   Writeln (x);
end.
0,0(0 оценок)
Ответ:
dron1131
dron1131
03.06.2023 01:09
{uses Crt;}
{Для древних сред Паскаль, работающих в DOS-режиме, снять комментарии
 в операторах uses, ClrScr, ReadKey }
const
  n = 10;
var
  a: array[1..n, 1..n] of integer;
  i, j, min, max: integer;
begin
  Randomize;
  {ClrScr;}
  Writeln('Исходный массив');
  max:=-100; min:=100;
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := Random(81)+10;
      Write(a[i,j]:3);
      if max<a[i,j] then max:=a[i,j]
      else
        if min>a[i,j] then min:=a[i,j]
    end;
    Writeln
  end;
  Writeln('min=',min:2,', max=',max:2);
  {ReadKey}
end.

Тестовое решение:
Исходный массив
 38 43 63 12 80 87 22 82 39 52
 88 82 79 35 68 67 66 63 84 85
 78 48 46 26 63 71 32 71 86 45
 11 38 55 12 75 85 68 13 64 88
 87 16 27 26 74 34 88 76 26 25
 74 45 17 18 43 81 88 46 40 18
 65 41 87 85 51 59 36 76 51 73
 90 63 89 87 88 71 31 29 43 38
 74 47 55 70 61 56 31 46 60 84
 88 31 64 56 32 55 19 32 66 24
min=11, max=90
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота