В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

1.Составить программу на Паскале для вывода таблицы значений функции y = 12 x2+2 на отрезке [-4; 5] с шагом 1. На проверку нужно прислать код программы и результат работы в виде скриншота. 2.Найти сумму положительных, произведение и количество отрицательных из 10 введенных целых значений ( ):
-7; 12; 13,5; -2; 0; 16; -4; 10,3; 1; -10,3.
Код программы написать на Паскале.
3.Составить блок-схему алгоритма и программу на Паскале для обработки массива из 15 чисел. Вычислить произведение и количество элементов, не равных нулю и больше 5.
4.Написать программу на Паскале для решения задачи: дано целое число b и натуральное (целое неотрицательное) число m. Вычислить b в степени m. На проверку прислать код программы и результат работы кода в виде скриншота окна программы с введенными входными данными

Показать ответ
Ответ:
taisijaljalko
taisijaljalko
06.08.2022 19:26
Var
  n, k, d2, d1, d0: integer;
  e2, e1, e0: integer;

procedure GetDigits(m: integer; var d2, d1, d0: integer);
{Перевод числа [100..FFF]в 16-ю систему счисления}
begin
  d0 := m mod 16;
  m := m div 16;
  d1 := m mod 16;
  d2 := m div 16
end;

begin
  n := 0;
  {Рассматриваем шестнадцатиричные числа от 100 до 7FF}
  for k := $100 to $7FF do
  begin
    GetDigits(k, d2, d1, d0);
    if (d2 = 2) or (d1 = 2) or (d0 = 2) then
    begin
      GetDigits(2 * k, e2, e1, e0);
      if d0 + d1 + d2 = e0 + e1 + e2 then n := n + 1
    end
  end;
  writeln('n=', n)
end.

Тестовое решение:

n=23
0,0(0 оценок)
Ответ:
gatshow029
gatshow029
26.03.2021 03:29
Type
  St = record
    iquo: integer; {целая часть}
    irem: integer; {числитель дроби}
    idiv: integer; {знаменатель дроби}
  end;

function iMax(i, j: integer): integer;
begin
  if i > j then iMax := i else iMax := j
end;

function iMin(i, j: integer): integer;
begin
  if i < j then iMin := i else iMin := j
end;

function FR(i, j, k: integer): St;
var
  nmax, nmin: integer;

begin
  nmax := iMax(iMax(i, j), k);
  nmin := iMin(iMin(i, j), k);
  with Result do
  begin
    iquo := nmax div nmin;
    idiv := nmin;
    irem := nmax mod nmin
  end
end;

var
  a, b, c: integer;
  r: St;

begin
  write('Введите через пробел три целых числа:');
  readln(a, b, c);
  r := FR(a, b, c);
  writeln('Результат работы функции: ', r.iquo, ' целых и ', r.irem, '/', r.idiv)
end.

Тестовое решение:

Введите через пробел три целых числа:343 253 37
Результат работы функции: 9 целых и 10/37
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота