1. Составить программу нахождения суммы чисел от 1 до 50 и вывода на экран полученного результата. 2. Найдите ошибки в программе и исправьте их:
Program z2
Var a, b, s: integer;
Begin;
A=10;
B:=6
S:=A+B;
Writeln (S;
End
3. Составить программу нахождения произведения чисел от 1 до 5 с оператором While.
4. Составить программу нахождения произведения чисел от 1 до 5 с оператором For.
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int number; //Вводимое число
int difference_first, difference_second; //переменные проверки арифм. прогр.
cout << "Enter three digit number: "; cin >> number; //ввод трехзначного числа
while(number < 100 or number >= 1000){
//проверка числа на трехзначность
cout << "Error!\nEnter three digit number: "; cin >> number;
}
difference_first = number % 10 - (number / 10 % 10); //разница между третьей цифрой и второй
difference_second = (number / 10 % 10) - (number / 100 % 10); // разница между второй цифрой и первой
if(difference_first == difference_second){ // если эти разницы равны, значит
cout << "YES!" << endl; // вывод, ДА
}else cout << "NO!" << endl; // иначе, НЕТ
system("pause");
return 0;
}
признаком разветвляющегося алгоритма является наличие операций проверки условия. различают два вида условий – простые и составные.
простым условием (отношением) называется выражение, составленное из двух арифметических выражений или двух текстовых величин (иначе их еще ), связанных одним из знаков:
< - меньше,
> - больше,
< = - меньше, или равно
> = - больше, или равно
< > - не равно
= - равно
например, простыми отношениями являются следующие:
x-y> 10; k< =sqr(c)+abs(a+b); 9< > 11; ‘мама’< > ‘папа’.
в примерах первые два отношения включают в себя переменные, поэтому о верности этих отношений можно судить только при подстановке некоторых значений:
если х=25, у=3, то отношение x-y> 10 будет верным, т.к. 25-3> 10
если х=5, у=30, то отношение x-y> 10 будет неверным, т.к. 5-30< 10
проверьте верность второго отношения при подстановке следующих значений:
а) k=5, a=1, b=-3, c=-8
b) k=65, a=10, b=-3, c=2